Ask Your Question

[Fedora 28] failed to boot after system update with installed Nvidia driver from RPM Fusion -Nonfree- NVIDIA Driver

asked 2018-05-24 09:43:51 -0500

rainerp gravatar image

Hello I have updated my Fedora 28 system today and can't boot into gdm anymore. A grey screen with an issuewarning tells me a problem which cannot be solved happend. After uninstalling the Nvidia driver and a reboot system starts fine.

My specs:

AMD® A6-6400k apu with radeon(tm) hd graphics × 2 Nvidia Gt1030

edit retag flag offensive close merge delete


Why have I problems with gdm after install rpmfusion nvidia driver? , and you have been able to install that driver without issue, please explain us because I always get stuck after type my password on the gdm screen, and here my first trouble case

christianbueno gravatar imagechristianbueno ( 2018-07-12 12:24:49 -0500 )edit

3 Answers

Sort by » oldest newest most voted

answered 2018-05-24 11:32:23 -0500

clnetbox gravatar image

updated 2018-05-27 06:40:14 -0500

I faced the same problem after running dnf upgrade today.
The issue most certainly is related to selinux-policy-targeted.
That package was also upgraded, alongside with the kernel.
We have 3 options (as a workaround) to solve this problem :

  • Remove the NVIDIA drivers (what you did) and wait until a new fixed selinux package gets released.
  • Downgrade selinux-policy-targeted package -> sudo dnf downgrade selinux-policy-targeted
  • Temporarily disable SELinux or set it to permissive (though this is definitely not recommended).

References : Post from user ggrogg on reddit community | Post from user ggrogg on reddit community

Update 2018-05-25 : An updated selinux-policy package which includes a fix is already in the works -> current status pending / request testing

Update 2018-05-26 : Now the current status has changed to testing and the request changed to stable. Update 2018-05-27 : The current status has changed to stable, so the final fixed version was released.

edit flag offensive delete link more


setenforce 0 only have effect until next reboot. To determine if you have a SELinux issue, setenforce 0 can be very useful, You will still get the SELinux alert messages if you have that enabled.

villykruse gravatar imagevillykruse ( 2018-05-24 12:36:03 -0500 )edit

@villykruse : You are right, so I've updated that part to make it more clear. Thanks for your contribution. :)

clnetbox gravatar imageclnetbox ( 2018-05-25 04:10:04 -0500 )edit

yes , all working well with the new selinux version 3.14.1-29.fc28, on kde plasma , on gnome always i get problems with gdm.

christianbueno gravatar imagechristianbueno ( 2018-05-26 22:07:25 -0500 )edit

still facing the problem with gmd although selinux-policy3.14.1-30 is installed

loeweh gravatar imageloeweh ( 2018-06-02 09:55:17 -0500 )edit

answered 2018-05-24 12:24:51 -0500

Tim4 gravatar image

Bug fix released.

You can manually install it or wait when it will be available in 'Stable' repo.

edit flag offensive delete link more



Yay! Can confirm the updated packages work for me.

I logged in over ssh, downloaded the updated selinux-policy and selinux-policy-targeted RPMs from the linked pages, and installed them manually with rpm. Rebooted and my desktop's back. :D

brion gravatar imagebrion ( 2018-05-25 09:31:08 -0500 )edit

answered 2018-05-24 19:32:50 -0500

pszabo gravatar image

The same thing happened to me. My whole system became unbootable. I booted into emergency mode and set SELinux method to permissive in /etc/selinux/config After that Fedora booted just fine. If you choose this method do not forget to re-enable SELinux after the fixed policy update is installed.

edit flag offensive delete link more

Question Tools



Asked: 2018-05-24 09:43:51 -0500

Seen: 2,081 times

Last updated: May 27 '18