Ask Your Question
1

[Fedora 28] ACPI error when booting

asked 2018-05-22 10:24:06 -0500

rick89 gravatar image

updated 2018-05-24 09:28:18 -0500

I see these ACPI errors when I boot in Fedora 28. How can I hide this from appearing in my computer when I boot in Fedora?

I added the parameter acpi=off and libata.noacpi=1 to the kernel, but it didn't work.

Video: link text

image description

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2018-05-22 11:06:59 -0500

These errors are being reported by the kernel because the kernel and the firmware are disagreeing about how the hardware should be initialized. Yes, they're annoying messages, but getting rid of them requires either kernel changes (which are currently being discussed upstream) or firmware changes (also being discussed), or both. In the meantime, unless there is some bit of hardware that is not working, these can most likely be ignored.

One could turn down the kernel message level from dmesg so that only horrible failures are shown, but I would not recommend it. Eventually, kernel maintainers upstream will decide on a solution and it will get picked up by Fedora; personally, I would just wait for that to happen, or get involved in the upstream efforts to fix the underlying issue.

edit flag offensive delete link more
0

answered 2018-05-22 20:56:19 -0500

PaulD gravatar image

updated 2018-05-22 21:09:30 -0500

Your problem is related to your USB conroller. Could you give the output of lspci | grep USB | grep Controller ? Does your USB work in general? Only with ACPI=off Do the devices seems reasonably fast for USB2 devices?

libata.noacpi should be related to Hard disk, DVD writer, etc.

You could # dnf install acpica-tools that would give you access to acpidump command, but I guess unless you want to open a bug, the output would be over what we/I would expect here.

It seems Linus Torvalds have asked about this same error: https://lkml.org/lkml/2016/10/5/341

edit flag offensive delete link more

Comments

Oh wait, I guess you was able to take this picture because it did hang there? You may try acpi_rev_override as kernel parameter... was used for Dell XPS 9560

acpi_rev_override [ACPI] Override the _REV object to return 5 (instead of 2 which is mandated by ACPI 6) as the supported ACPIspecification revision (when using this switch, it may be necessary to carry out a cold reboot _twice_ in a row to make it take effect on the platform firmware).
PaulD gravatar imagePaulD ( 2018-05-22 22:19:15 -0500 )edit
rick89 gravatar imagerick89 ( 2018-05-24 09:20:30 -0500 )edit
0

answered 2018-05-24 09:37:30 -0500

rick89 gravatar image

updated 2018-05-24 10:07:52 -0500

I booted with this configuration but it shows the same errors.

image description

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2018-05-22 10:24:06 -0500

Seen: 1,769 times

Last updated: May 24 '18