Ask Your Question

Please how avoid problems on GDM after install nvidia drivers from rpmfusion on fedora 28 workstation

asked 2018-05-12 11:56:20 -0500

christianbueno gravatar image

updated 2018-07-14 11:27:04 -0500

I have installed any times f28 workstation but always gets the same problem in the GDM login screen .

When the login screen is displayed and after typed my password the problems appears , fedora gets stuck with the gray background colour and none of tty works ( CTRL+ALT+ Fn ).
I tested on fedora 28 KDE plasma spin and all work fine there but I like gnome , please help us to find a solution.
And Why does on KDE plasma after login screen all work fine and not on Gnome?

edit retag flag offensive close merge delete


@christianbueno , I'm not testest but here it is -> fedora-nvidia-guide

hhlp gravatar imagehhlp ( 2018-05-12 11:58:59 -0500 )edit

I know about that web. I have tested it in the past with similar problems

christianbueno gravatar imagechristianbueno ( 2018-05-12 12:09:18 -0500 )edit

I think that taking off GDM and installing SDDM could be a solution but how install SDDM the login screen of KDE plasma

christianbueno gravatar imagechristianbueno ( 2018-05-12 12:11:12 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2018-07-12 13:46:26 -0500

christianbueno gravatar image

updated 2018-07-12 13:53:16 -0500

On fedora 28 workstation

Now you can successfully solve the GDM issue.

The solution is change gdm(display manager) to another , for example lightdm. You must run your pc without a GUI interface, you could do that by change run level to 3 on GRUB2.

First you have to change runlevel to 3
Login with your user name account and password.
Then install lightdm

$ sudo dnf install lightdm

Now disable gdm.service and enable lightdm

$ sudo systemctl disable gdm.service
$ sudo systemctl enable lightdm

Stop gdm and start lightdm

$ sudo systemctl stop gdm
$ sudo systemctl start lightdm

Then reboot your pc

$ reboot

thanks pals, greetings from Ecuador, you could use open drivers but if you like to install proprietary driver , it is possible on fedora 28 workstation.

edit flag offensive delete link more

answered 2018-05-14 10:32:40 -0500

rbmorse gravatar image

The guide linked above looks promising, but I found this one:


which seems to be closer to home and solved the gdm issue I was having with the proprietary nvidia drivers.

edit flag offensive delete link more

Question Tools



Asked: 2018-05-12 11:56:20 -0500

Seen: 743 times

Last updated: Jul 14 '18