Access NTFS partition in Fedora 28

asked 2018-05-11 08:26:12 -0500

kaf-laarous gravatar image

updated 2018-05-11 08:30:56 -0500

I cant access (Move or ctrl+x, Delete, rename) my Files/Folders in partition ntsf in Fedora 28! ntfs-3g is installed.

edit retag flag offensive close merge delete

Comments

@kaf-laarous is your partition share with windows?, is so the Windows partition is not cleanly unmounted, and linux will refuse to mount it in R/W mode. otherwise Try remounting manually (as root) with no option, and post the output here, with the command sudo lsblk give you the partition and then do:

umount /dev/partition
ntfs-3g /dev/partition /mnt
hhlp gravatar imagehhlp ( 2018-05-11 10:25:05 -0500 )edit

You need to disable “quick boot” in Windows, or whatever it’s called.

florian gravatar imageflorian ( 2018-05-11 11:58:51 -0500 )edit
1

Disable Fast Shutdown, as @florian stated.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-05-11 12:47:32 -0500 )edit

sudo lsblk

NAME            MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda               8:0    0   1,8T  0 disk 
├─sda1            8:1    0   450M  0 part 
├─sda2            8:2    0   116M  0 part /boot/efi
├─sda3            8:3    0     1G  0 part /boot
├─sda4            8:4    0   146G  0 part 
├─sda5            8:5    0   341G  0 part 
│ ├─fedora-root 253:0    0    50G  0 lvm  /
│ ├─fedora-swap 253:1    0   7,9G  0 lvm  [SWAP]
│ └─fedora-home 253:2    0 283,1G  0 lvm  /home
└─sda6            8:6    0   1,4T  0 part
kaf-laarous gravatar imagekaf-laarous ( 2018-05-12 11:13:58 -0500 )edit

sudo ntfs-3g /dev/sda6 /mnt

The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Falling back to read-only mount because the NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting.)

kaf-laarous gravatar imagekaf-laarous ( 2018-05-12 11:14:32 -0500 )edit