Bluetooth headphones not working with F28

asked 2018-05-03 22:18:41 -0500

dharmit gravatar image

I upgraded to F28 couple of days back and have been struggling to use my bluetooth headphones with it. In F27, I had to exclude blueman package from updating to keep it working. However, to move to F28, I had to update it.

Blueman doesn't give me a profile option of "Headphones" anymore. It shows me only "Serial Port" and "Don't Connect" as the two options.

I tried blueberry as well. It does connect to the headphones and I see various options in Volume Control for headphones. But the audio being sent to headphones is not really clear. Also, it keeps getting disconnected automatically and intermittently.

I'm running a fully updated F28 system with i3wm. I tried logging into gnome but that doesn't work. And I don't want to be opening gnome unless really required. How do I fix this issue and get bluetooth headphones working with F28?

edit retag flag offensive close merge delete

Comments

Got this fixed with the help of Red Hat BZ & Freedesktop BZ. Doing headset=auto specifically helped fixed my issue.

dharmit gravatar imagedharmit ( 2018-05-04 01:32:58 -0500 )edit