Help diagnosing potential Wayland problem with Rawhide

asked 2018-04-26 23:09:43 -0500

bob323 gravatar image

I recently upgraded my laptop from Fedora 27 to Rawhide. After testing it out with no problems, I upgraded my desktop to Rawhide as well. However, on my desktop, when opening a new window in my browser (Vivaldi), Gnome crashes. I found that logging out and changing my session to GNOME (Xorg) fixes the problem. Since this problem didn't occur on my laptop, I went to see if

  1. I was running Wayland or X11 on my laptop, and

  2. Whether or not the problem occurred under Wayland.

I logged out on my laptop and tried to ensure that the session was set to use Wayland, but only had two options: GNOME or GNOME Classic. I have options for GNOME, GNOME Classic, and GNOME (X11) on my desktop. Both options available for my laptop show that the session runs under X11 using loginctl show-session 2 -p Type (the session number is variable depending on how many times I've logged out and logged back in without restarting). Even after installing the wlc, wlc-devel, and wayland-devel packages, I don't have the login option for Wayland.

How can I install Wayland to test for this bug?

edit retag flag offensive close merge delete