Ask Your Question

Sempron APU Graphics segfault in lightdm

asked 2018-04-18 05:06:33 -0500

felthat gravatar image

updated 2018-04-19 08:08:51 -0500

fcomida gravatar image

I have installed the Fedora 28 XFCE spin, and am very impressed with the work you have done. I have one minor issue and I am only raising it because I am confused about what is happening and which drivers I should be using. This is a Sempron 3850 that uses [AMD/ATI] Kabini [Radeon HD 8280 / R3 Series] graphics. In Debian Buster, I just use the AMD ucode. What is happening is, I get the login window in lightdm, then when I put in my password, the screen goes blank, then I have to login to lightdm the 2nd time, then it works and I no longer see errors in dmesg. Here is the error I get:

[ 26.062943] showsignalmsg: 8 callbacks suppressed [ 27.683791] radeondpauxtransfernative: 74 callbacks suppressed [ 43.166719] radeondpauxtransfernative: 74 callbacks suppressed

Here is the output of lsmod

lsmod | grep radeon

radeon 1654784 3 i2calgobit 16384 2 amdgpu,radeon drmkmshelper 200704 2 amdgpu,radeon ttm 126976 2 amdgpu,radeon drm 454656 8 amdgpu,radeon,gpusched,ttm,drmkms_helper

And here is the part of the boot log where it appears to load the Kabini microcode, then also loads the radeon driver:

[    5.594069] [drm] radeon kernel modesetting enabled.
[    5.597263] checking generic (c0000000 300000) vs hw (c0000000 10000000)
[    5.597265] fb: switching to radeondrmfb from EFI VGA
[    5.600370] Console: switching to colour dummy device 80x25
[    5.601237] [drm] initializing kernel modesetting (KABINI 0x1002:0x9836 0x1458:0xD000 0x00).
[    5.601279] [drm] doorbell mmio base: 0xD0000000
[    5.601286] [drm] doorbell mmio size: 8388608
[    5.601375] ATOM BIOS: AMD
[    5.601460] radeon 0000:00:01.0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
[    5.601473] radeon 0000:00:01.0: GTT: 2048M 0x0000000020000000 - 0x000000009FFFFFFF
[    5.601488] [drm] Detected VRAM RAM=512M, BAR=256M
[    5.601495] [drm] RAM width 128bits DDR
[    5.601633] [TTM] Zone  kernel: Available graphics memory: 3795232 kiB
[    5.601641] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[    5.601648] [TTM] Initializing pool allocator
[    5.601664] [TTM] Initializing DMA pool allocator
[    5.601717] [drm] radeon: 512M of VRAM memory ready
[    5.601726] [drm] radeon: 2048M of GTT memory ready.
[    5.601752] [drm] Loading kabini Microcode
[    5.602121] [drm] Internal thermal controller without fan control
[    5.602793] [drm] radeon: dpm initialized
[    5.602989] [drm] Found UVD firmware Version: 1.64 Family ID: 9
[    5.606086] [drm] Found VCE firmware/feedback version 40.2.2 / 15!
[    5.606117] [drm] GART: num cpu pages 524288, num gpu pages 524288
[    5.633154] [drm] PCIE GART of 2048M enabled (table at 0x000000000030E000).
[    5.633457] radeon 0000:00:01.0: WB enabled
[    5.633505] radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0x00000000fc907248
[    5.633519] radeon 0000:00:01.0: fence driver on ring 1 use gpu addr 0x0000000020000c04 and cpu addr 0x000000001ea94925
[    5.633531] radeon 0000:00:01.0: fence driver on ring 2 use gpu addr 0x0000000020000c08 ...
edit retag flag offensive close merge delete


Here is the output of inxi, which is the same as my Debian install

# inxi -Gxxx

Graphics: Card: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8280 / R3 Series] bus-ID: 00:01.0 chip-ID: 1002:9836 Display Server: x11 ( 1.19.6 ) drivers: ati,radeon (unloaded: modesetting,fbdev,vesa) Resolution: 1920x1080@60.00hz OpenGL: renderer: AMD KABINI (DRM 2.50.0 / 4.16.0-0.rc4.git0.1.fc28.x86_64, LLVM 6.0.0) version: 4.5 Mesa 18.0.0 (compat-v: 3.0) Direct Render: Yes

felthat gravatar imagefelthat ( 2018-04-18 21:14:29 -0500 )edit

I am wondering about this "error 4 in". Maybe lightdm is using cairo for compositing, but I have the native XFCE compositor enabled, so it throws this error when XFCE starts? I will disable compositing in XFCE and see if I still get these errors on startup.

felthat gravatar imagefelthat ( 2018-04-18 21:19:06 -0500 )edit

# lshw -c video *-display
description: VGA compatible controller product: Kabini [Radeon HD 8280 / R3 Series] vendor: Advanced Micro Devices, Inc. [AMD/ATI] physical id: 1 bus info: pci@0000:00:01.0 version: 00 width: 64 bits clock: 33MHz capabilities: pm pciexpress msi vgacontroller busmaster cap_list rom configuration: driver=radeon latency=0 resources: irq:37 memory:c0000000-cfffffff memory:d0000000-d07fffff ioport:f000(size=256) memory:feb00000-feb3ffff memory:c0000-dffff

felthat gravatar imagefelthat ( 2018-04-19 04:01:21 -0500 )edit

I disabled the XFCE compositor, and am able to login without the segfault error in the lightdm-greeter, but I see this message consistently:

[   61.330422] radeon_dp_aux_transfer_native: 158 callbacks suppressed

[ 677.372285] radeondpauxtransfernative: 116 callbacks suppressed [ 687.197333] radeondpauxtransfernative: 74 callbacks suppressed [ 792.584531] radeondpauxtransfernative: 32 callbacks suppressed [ 802.665877] radeondpauxtransfernative: 74 callbacks suppressed

I haven't notice any performance issues, though

felthat gravatar imagefelthat ( 2018-04-19 04:06:01 -0500 )edit

It seems both amdgpu and radeon are loaded and your gpu is driven by radeon. Maybe you have to blacklist amdgpu or you can try to blacklist radeon and see if amdgpu works better (if it even works at all). Please post the output of dmesg | grep -P "(radeon|amdgpu)"

fcomida gravatar imagefcomida ( 2018-04-19 08:26:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-04-19 04:15:31 -0500

sideburns gravatar image

Welcome to ask.fedora! This may be more of an Xfce issue than a Fedora issue. You might want to go over to the Xfce Forum and ask there as well. They're a friendly, knowledgeable bunch, and may know just what you need.

edit flag offensive delete link more


Thanks, yeah I guess this is something within the lightdm-greeter code because it was also reported on Arch. The "radeondpauxtransfernative: 74 callbacks suppressed" just started showing up on my Debian install with an upgrade to the 4.15 kernel. I think I will just switch to a different display manager for now. I posted the issue because I thought the XFCE Fedora spin project might want feedback on this, and didn't see any other way to contact anyone.

felthat gravatar imagefelthat ( 2018-04-19 19:36:25 -0500 )edit

I had a similar problem with Fedora 28 using Xfce on a computer that contained an AMD Radeon R7 250. After enabling the display connected to that video adapter and logging out, I too would get an X restart whenever I tried logging back in via lightdm. I had to SSH in and remove my Xfce configuration files before I could log back in via lightdm. (Of course, the display connected to the Radeon would then be reset to disabled.)

I just installed Fedora 29 and this problem has completely gone away. Thought I'd comment here in case you want to give it a try, too.

bhoefer gravatar imagebhoefer ( 2018-11-08 20:48:29 -0500 )edit

Question Tools


Asked: 2018-04-18 05:06:33 -0500

Seen: 182 times

Last updated: Apr 19 '18