Ask Your Question

Dependency problems with dnf system-upgrade to FC27

asked 2018-04-09 05:55:48 -0500

l1nuxfan gravatar image

Hi community,

I have trouble upgrading FC26 to FC27. Running

dnf system-upgrade download --releasever=27

leads to the error (after download of packages):

Running transaction check
Error: transaction check vs depsolve:
(php-composer(sabre/xml) >= 1.5 with php-composer(sabre/xml) < 3) is needed by php-sabre-vobject4-4.1.5-1.fc27.noarch
(php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2) is needed by composer-1.6.3-4.fc27.noarch
(php-composer(composer/semver) >= 1.0 with php-composer(composer/semver) < 2) is needed by composer-1.6.3-4.fc27.noarch
(php-composer(composer/spdx-licenses) >= 1.2 with php-composer(composer/spdx-licenses) < 2) is needed by composer-1.6.3-4.fc27.noarch
(php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2) is needed by composer-1.6.3-4.fc27.noarch
(php-composer(seld/cli-prompt) >= 1.0 with php-composer(seld/cli-prompt) < 2) is needed by composer-1.6.3-4.fc27.noarch
(php-composer(seld/jsonlint) >= 1.4 with php-composer(seld/jsonlint) < 2) is needed by composer-1.6.3-4.fc27.noarch
(php-composer(seld/phar-utils) >= 1.0 with php-composer(seld/phar-utils) < 2) is needed by composer-1.6.3-4.fc27.noarch
To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'.
You probably have corrupted RPMDB, running 'rpm --rebuilddb' might fix the issue.
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.

Running the diagnose + rebuilddb commands do not help, they produce no output. Any hints what I can do?


edit retag flag offensive close merge delete


What source did you install PHP-composer from?

florian gravatar imageflorian ( 2018-04-09 12:55:58 -0500 )edit

I did not manually install php-composer, must have been installed along with other SW as a dependency. I circumvented the problem for the moment by uninstalling composer + dependend RPMs, will install again after the upgrade.

l1nuxfan gravatar imagel1nuxfan ( 2018-04-10 01:35:47 -0500 )edit

Upgrade + restinalling of packages was successful so this topic can be closed.

l1nuxfan gravatar imagel1nuxfan ( 2018-04-10 04:13:23 -0500 )edit

Topics here aren’t closed. You can rather answer your own question and mark it as the correct answer.

florian gravatar imageflorian ( 2018-04-12 18:41:04 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2018-04-17 04:42:39 -0500

remi gravatar image

This is known issue.

RPM in Fedora 27 introduce a new feature which allow to describe "range dependencies" (the "with" keyword).

As this feature is not supported by RPM in older version, this may raise such issue during system upgrade.

So removing the packages before the update, and re-installing them after if the proper way.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-04-09 05:55:48 -0500

Seen: 210 times

Last updated: Apr 17 '18