Ask Your Question
1

WARNING **: Could not open X display No protocol specified in almost all apps - f27

asked 2018-04-08 07:36:34 -0500

B4rt gravatar image

Hi all.

I bought a Precision 5520 and installed Fedora 27 on it. I had a problem with the graphic card (Intel Graphic card 630). Fedora wasn't recognizing it... it was working but the performance was REALLY slow.

After lots of research, I finally found the answer... go to the grub configuration and erase the nomodeset and voiala ! Fedora recognize my gcard and my life started to run much better...

Althought, for my bad luck... lots of apps stoped to work ! When I run then on shell, I have the error:

* (vmware-modconfig:20991): WARNING *: Could not open X display No protocol specified

(vmware-modconfig:20991): Gtk-WARNING **: cannot open display: :0

VMware example !

Please, anyone has any clues what is going on? How to solve it? I am available to give more information if it is necessary.

Thanks.

edit retag flag offensive close merge delete

Comments

Wayland does not allow you to run graphical applications as root user. You may want to run a XOrg session or use other workarounds. The topic has been covered many times in this forum. Let us know if you can't find the information you need.

florian gravatar imageflorian ( 2018-04-08 16:08:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-04-10 01:17:21 -0500

B4rt gravatar image

Hi,

yep, I realized that I am running Wayland and now most of all applications are running cause I changed some configurations.

Looking forward to seeing Wayland improvements. Laptop monitor is 4k, and when I connect a monitor, Wayland can keep different scales, although some applications when in the monitor screen the scale is fine, but if I move to the 4k screen, the window become very small. This happens only with some applications

Many thanks !

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-04-08 07:36:34 -0500

Seen: 485 times

Last updated: Apr 08 '18