Ask Your Question
2

How to stop Flatpaks from showing up it the Software

asked 2018-04-01 13:32:57 -0500

TomsT gravatar image

I'm not a big fan of managing and using flatpaks instead of normal packages, but I keep accidentally installing them from the gnome-software. I know well enough how to remove flatpak-ed programs themselves from my system (flatpak uninstall).

Again, the question is: How to remove the dl.flathub.org repository (or any other flatpak repositories); or disable anything else Flatpak related from my Fedora 27 system if that is a way to go in order to resolve the situation explained above?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2018-04-01 17:31:44 -0500

christianbueno gravatar image

Hello, on fedora workstation , open Software center then on the top left click on the application icon , next select repositories sources or any like that, there you could check and uncheck the flatpak remote sources.

edit flag offensive delete link more

Comments

Hi,thanks! If I go to the Repository sources from the default Software application, I see a list of all repos (including flathub), but the only thing I can check/uncheck is called "Proprietary software sources" (which, as far as I can tell, is not what I need). I cannot enable/disable any repos or anything else. And grep "flathub" /etc/yum.repos.d./* doesn't give me any results. Similarly I don't see flathub repo in dnfdragora, so I figured out there must be a different repo mechanism and tools for flatpaks. Or is my system broken?

TomsT gravatar imageTomsT ( 2018-04-02 02:18:19 -0500 )edit
0

answered 2018-04-03 12:59:45 -0500

TomsT gravatar image

Sincere thanks for the help, Chistian! Although these solutions didn't help in my case (maybe I had manually deleted something for it to work), they finally led me to a simple re-action that did remove the repo.

Solution for me was:

Going to the flathub.org page and "pretending" to set up the flathub repository again ( quick setup —> Fedora on that page) leads to downloading the flathub.flatpakrepo file which, when opened with Gnome Software, (if the repo is already set up) gives instead a simple option to remove it.

edit flag offensive delete link more
0

answered 2018-04-02 21:48:56 -0500

christianbueno gravatar image

Open Gnome-Software, in the search space type gnome-software then click on it, in the bottom of its information you could uncheck the flatpaks sources.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-04-01 13:32:57 -0500

Seen: 1,257 times

Last updated: Apr 02 '18