Ask Your Question
0

Fedora infinity wallpaper displaying incorrectly

asked 2018-03-05 14:45:09 -0500

bob323 gravatar image

updated 2018-03-05 15:10:01 -0500

I'm trying to use the Fedora infinity wallpaper from the fedorainfinity-backgrounds package. When trying to use the animated wallpaper, at first the desktop only displayed a black background. I checked the animation xml file against an xml file for the wallpaper included with Fedora 27 and they both use the same syntax. I tried changing my clock format from 12h to 24h, which got the background to slowly fade into view, but it's still almost completely black and the visible part is very dim. It's currently 2:43 in the afternoon where I am so the background should be displaying the daytime picture at full brightness. How can I fix this?

Edit: I changed the animation start time to be 16:00 today (with clock format set back to 12h) and the background now shows a very visible version of the "sunrise" background. That would put the animation roughly 1 hour away from beginning, meaning it's reading the wrong time by around 8 hours. I'm thinking this has to be some discrepancy between the displayed time and the system time. I'll keep working on this.

Output of date if it's important:

date
Mon Mar  5 15:00:10 CST 2018
edit retag flag offensive close merge delete

Comments

Is perhaps location services (within the privacy tab) necessary for this to work?

Jos gravatar imageJos ( 2018-03-05 15:36:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-06 12:02:05 -0500

bob323 gravatar image

updated 2018-03-06 12:03:03 -0500

I've fixed the problem. Here's how to make this work:

  1. sudo dnf install fedorainfinity-backgrounds
  2. sudo mv /usr/share/backgrounds/infinity /usr/share/backgrounds/gnome/
  3. sudo sed -i -e 's/\/usr\/share\/backgrounds\/infinity/\/usr\/share\/backgrounds\/gnome\/infinity/g' /usr/share/backgrounds/gnome/infinity/infinity.xml (this just updates the paths for all images the xml file references to reflect the new location)
  4. Install Gnome Tweaks
  5. Open Tweaks and go to the Desktop menu
  6. Select your infinity.xml file as the background image.

I don't know why the time is so messed up with the files outside the gnome folder, but putting them inside the gnome folder works. Also, doing this makes the background disappear from the system settings menu, but Gnome Tweaks works. Since you only have to do this once (assuming you don't change backgrounds that often) I don't think it's too bad of a workaround.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-03-05 14:45:09 -0500

Seen: 312 times

Last updated: Mar 06 '18