Ask Your Question
1

System unusably slow after upgrading to nvidia 390.25 driver

asked 2018-02-18 17:42:44 -0500

fringmar gravatar image

Hi! The offline update just installed the latest NVidia driver, 390.25. The system is otherwise a fully up-to-date F27, using the Gnome 3 desktop environment.

Since the update, the graphical system is so slow as to be barely usable, starting from the login screen. The mouse pointer barely moves, keystrokes are registered but with delays of one to two seconds, and generally everything is slow like this, including desktop animations etc. It almost seems like it is a general slowdown that keeps the system busy for one or two seconds, then processes inputs for a few millisecs, then is busy again. Logging in takes one to two minutes, launching applications similarly. Booting the multiuser target works, the system operates at normal speed then.

Also my screen configuration does not work. I'm using a laptop but usually have the internal screen off, only using an external one that's connected via HDMI. This seems to indicate that something with the driver or something in the X system does not work as intended.

I've spent an hour poking around but can't find the cause: journalctl, dmesg, xorg log -- nothing shows anything interesting.

I've had a lot of problems with the nvidia drivers in the past, but they could typically be resolved by booting the multiuser target, then forcing akmod to reinstall. Not now though, it keeps being slow.

Any hints about what I could try next? I'm fairly certain it is the driver, but it may be something else also, so how do I find out? I'd be fine with downgrading the driver for now, but to be honest I don't know how to that, and the dnf history doesn't seem to show the offline installation (last entry is from a manual update a few days ago).

edit retag flag offensive close merge delete

Comments

I guess offline updates are managed by PackageKit, not dnf. Download previous working NVIDIA-xxxx.run from Nvidia website, locate newly installed NVIDIA-xxxx.run somewhere under /etc/sysconfig and replace it with the older one. Reboot and akmod will take care of rebuilding it.

fcomida gravatar imagefcomida ( 2018-02-18 19:08:37 -0500 )edit

Thanks! Unfortunately there is no NVIDIA-Linux-....run package anywhere on my system, except a very old one that I've downloaded a long time ago. Any other hints in that direction?

Meanwhile I've tried a complete de-installation and re-installation of the akmod and all nvidia libs via dnf. Didn't help one bit.

I also found out that the slowdown comes from the process gnome-shell burning my CPU, all 16 cores of it. Could be any number of things I guess.

Next I'll try a manual installation of the driver, removing the akmod. Gaaah, that's what I really want to avoid.

fringmar gravatar imagefringmar ( 2018-02-19 08:39:13 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2018-02-20 10:59:57 -0500

kogli gravatar image

This exact same thing happened to me today, I could have written this question myself. I am saying this because I found the perfect solution for myself, it is therefore likely to work in your case as well. It is surprisingly simple and I did not have to downgrade the driver.

Edit the file /etc/gdm/custom.conf and uncomment the line WaylandEnable=false. Reboot. I just did and everything has worked as expected so far.

We all know that Wayland does not work with proprietary Nvidia drivers. It should automatically fallback to Xorg. It did until now, but the fallback stopped working with the new driver version, I guess.

edit flag offensive delete link more

Comments

Okay, this worked for me, too. But that is only gdm, right? Strange. It still must have been broken by the recent driver update. And no, I didn't know that Wayland isn't supposed to work. I was pretty sure that I've been using this set-up unchanged since switching to gnome-shell about a year ago.

fringmar gravatar imagefringmar ( 2018-02-22 13:12:42 -0500 )edit

This was the proper fix for my issue identical to the OPs. I think it's exactly as you say, it used to automatically fallback, so you would be silently pushed on to Xorg whatever you did, but now it just doesn't.

SgtLion gravatar imageSgtLion ( 2018-02-28 02:23:14 -0500 )edit

This sort of worked for me. Now gdm performs well, but as soon as I login, everything locks up. Mouse and keyboard don't respond. It looks like gnome shell is trying to start up but it never gets to a desktop.I can't even switch to another virtual console. My work around has been booting to multi-user.target (former run level 3), logging in as my regular user, and running "startx". Any suggestions?

rmatoi gravatar imagermatoi ( 2018-03-08 22:46:22 -0500 )edit
1

answered 2018-02-19 09:43:59 -0500

SteveEbey73701 gravatar image

start terminal

sudo init 3
sudo dnf remove *akmod*
sudo dnf remove *nvidia*
sudo dnf install dkms gcc acpid kernel-headers kernel-devel
./home/username/Downloads/NVIDIA...x86_64.run -Z

answer yes to dkms and yes or no to 32 bit, as per your own needs. if asked about existing library files, choose install and overwrite. Once the driver is installed, dkms will from this point forward, make kernel modules for you, with no dependence on rpm, akmods, or other people. I have run 390.25 for several kernel updates, and the rebuild has always been flawless. When the kernel update installs the kernel-devel for the new kernel, there is a 2 to 3 minute pause, while dkms rebuilds. Your system may be faster than mine, but the pause will probably be noticeable none the less. My system never slows down, and the games I play in linux and wine run slightly faster with 390.25 over any of the previous drivers. I am also testing Vulkan with Nvidia, and loving the results I get from that. After the driver installs and builds the kernel modules, you are asked about xconf, and I let it modify mine. I also run sudo nvidia-xconfig --cool-bits=12 to allow nvidia-settings to control and monitor fan and power, and clocks, so I can adjust as needed. Once everything is done, reboot, and see if your system performs any better. HTH.

edit flag offensive delete link more

Comments

Thanks, good hints all around. For now I've only manually installed the previous driver version (384.111), and it works fine, but I'm sure I'll get tired of the manual process after the next few kernel updates. I have only looked into dkms superficially so far, but if it works as you describe I might just switch over.

fringmar gravatar imagefringmar ( 2018-02-19 16:17:57 -0500 )edit

Been 3 years with nothing but nvidia proprietary and dkms. Only issue I ever had was when compiler changed to 7.3.1 in the kernel update, and I have to force an upgrade to gcc 7.3.1 on my system, but that had nothing to do with nvidia. People claiming that nvidia breaks, are probably not willing to own up to the problem being related to something else on the system.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-02-20 13:17:29 -0500 )edit
1

answered 2018-02-19 11:15:08 -0500

meeseeks gravatar image

Hi! I am also running F27 with the Gnome 3 desktop environment, in my case on a desktop with two monitors using a GeForce GT 730 video card, and I had the same problem with this upgrade of the latest NVidia driver. I also wasn't able to make use of the dnf history rollback feature because my box is not setup to cache previous packages in the repo, which are necessary for the rollback feature. So what I did was downgrade from 390 to 387 with dnf downgrade xorg-x11-drv-nvidia --allowerasing This was enough to stop the serious lag but I no longer had access to my second monitor, probably due to not having the nVidia kernel module to go with the downgrade version. I did try to manually create it using akmods --force from the command line with no success. I ended up deleting all the NVidia drivers and switching to nouveau as I'm tired of nVidia breaking things. But again this was only because I wanted to access my second monitor again, hopefully you can get a fairly normal situation with a downgrade.

edit flag offensive delete link more

Comments

Agreed, nVidia doesn't have a good track record with Linux. Akmod kept it off my back for about a year, and now this. Nouveau doesn't work too well with my laptop, and the nVidia drivers still offer some functionality that I'd like to continue using.

fringmar gravatar imagefringmar ( 2018-02-19 16:14:00 -0500 )edit
0

answered 2018-02-19 16:29:39 -0500

fringmar gravatar image

updated 2018-02-19 16:30:07 -0500

Fixed slowness by removing the 390.25 akmod:

sudo dnf remove akmod-nvidia xorg-x11-drv-nvidia*

Manually installed version 384.111. Everything works fine for now. Will check manual installation of 390.25 as well and raise the issue with nVidia (if that is even possible).

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2018-02-18 17:42:44 -0500

Seen: 3,730 times

Last updated: Feb 19 '18