Ask Your Question
1

Windows partition read-only [solved]

asked 2018-01-19 15:09:22 -0500

Helvio gravatar image

updated 2018-01-25 19:26:44 -0500

The windows partition mounts, but I only have read access only. How to solve this? Fedora 27 KDE

edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora. In order to help you, we'll need a tad more information. Please edit your question to include any line in the file /etc/fstab that refers to your Windows partition. If you can't find any, check in /etc/mtab because that lists everything currently mounted.

sideburns gravatar imagesideburns ( 2018-01-19 16:00:15 -0500 )edit

6 Answers

Sort by » oldest newest most voted
4

answered 2018-01-19 16:51:35 -0500

patocarr gravatar image

On Windows, check if Fast Start is enabled, and if it is, set it to disabled. This may take a bit longer to boot into Windows.

edit flag offensive delete link more
2

answered 2018-01-25 19:26:11 -0500

Helvio gravatar image

Solved!

After disable fast star, hibernate (in control panel), It failed to "kill" the hiberfil.sys file, which I did by running the CMD command: powercfg / hibernate off. After a full shutdown the partition got RW ...

edit flag offensive delete link more
1

answered 2018-01-20 07:33:33 -0500

Helvio gravatar image

updated 2018-01-20 07:34:09 -0500

in / etc / mtab I found   just the line below regarding the windows partition

/dev/sda3 /run/media/helvio/BA2E07B72E098E21 fuseblk ro,nosuid,nodev,relatime,userid=0,groupid=0,defaultpermissions,allowother,blksize=4096 0 0

Should I add this line in fstad? Is it correct?

I stress that the partition mounts and reads normally, it just does not have write permission

edit flag offensive delete link more

Comments

No, do not add that to /etc/fstab because the ro means "read only."

sideburns gravatar imagesideburns ( 2018-01-20 13:28:33 -0500 )edit

Can I add it this way then?

/dev/sda3 /run/media/helvio/BA2E07B72E098E21 fuseblk ,nosuid,nodev,relatime,userid=0,groupid=0,defaultpermissions,allowother,blksize=4096 0 0

Helvio gravatar imageHelvio ( 2018-01-23 19:05:13 -0500 )edit

No. the entire /run branch of the directory tree is in RAM, and doesn't survive a reboot, so the mountpoint won't exist. Create a directory in /mnt such as /mnt/windows and use that. It might work.

sideburns gravatar imagesideburns ( 2018-01-23 19:51:26 -0500 )edit
1

answered 2018-01-20 07:26:48 -0500

Helvio gravatar image

With Windows it is Ok because hibernation is disabled and also the partition mounts, but without permission to write

edit flag offensive delete link more

Comments

If Fast Start is enabled in Windows, the NTFS partitions are left in a state where it is not safe to write on them. That is why you will only get a read only permission. Please follow the suggestion given by patocarr.

jmt gravatar imagejmt ( 2018-01-20 20:08:01 -0500 )edit
0

answered 2018-01-23 19:03:44 -0500

Helvio gravatar image

Thank you, as soon as possible I will do this and put the result

edit flag offensive delete link more
0

answered 2018-01-25 09:28:57 -0500

Helvio gravatar image

Fast start - disablead / Hibernate: disabled / Windows OS completely off :-- even though it only continues as read-only

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2018-01-19 15:09:22 -0500

Seen: 1,291 times

Last updated: Jan 25 '18