Ask Your Question
0

[solved] Transmission-daemon changes settings in Fedora 27

asked 2018-01-19 09:37:30 -0500

updated 2018-01-20 02:00:48 -0500

I have installed transmission-daemon and it is working. However when I stop the service, change settings.json:

"rpc-whitelist": "*.*.*.*",
"rpc-whitelist-enabled": false,

And starts the service again, my changes do not work. When I stop the service again, settings.json looks like:

"rpc-whitelist": "*.*.*.*",
"rpc-whitelist": "127.0.0.1",
"rpc-whitelist-enabled": false,
"rpc-whitelist-enabled": true,

What is going on here? Line 2 and 4 are added. Result, I can only login to the Transmission web client from my Fedora machine and not from any other computer.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-01-20 02:01:23 -0500

Looks like Fedora 27 has an early implementation of a patch, which wasn't ok.

See https://github.com/transmission/trans...

Downgraded transmission-daemon to an earlier version. Solved.

edit flag offensive delete link more
0

answered 2018-01-20 22:50:24 -0500

Got same issue, downgraded to 2.92-8 and solved.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-01-19 09:37:30 -0500

Seen: 437 times

Last updated: Jan 20 '18