Ask Your Question
1

BCM4352 Drivers

asked 2018-01-19 09:24:57 -0600

dan_9k gravatar image

I found this set of instructions for installing BCM4352 drivers. I am using Fedora 27. My machine is a Dell Precision m4800.

I did the following

sudo dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-27.noarch.rpm
sudo dnf install http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-27.noarch.rpm
sudo dnf install kernel-devel broadcom-wl akmod-wl akmods
sudo akmods
sudo reboot

However, when I do sudo akmods the following happens:

Checking kmods exist for 4.13.9-300.fc27.x86_64            [  OK  ]
Files needed for building modules against kernel
4.13.9-300.fc27.x86_64 could not be found as the following
directories are missing:
/usr/src/kernels/4.13.9-300.fc27.x86_64/
/usr/lib/modules/4.13.9-300.fc27.x86_64/build/Is the correct kernel-devel package installed?                                               [FAILED]

I'm guessing that kernel-devel is not backwards compatible because when I do

sudo dnf install kernel-devel

Last metadata expiration check: 0:16:02 ago on Fri 19 Jan 2018 09:53:17 AM EST.
Package kernel-devel-4.14.13-300.fc27.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

What's the best way to get my wifi working? I've had no issues using Debian on this machine.

edit retag flag offensive close merge delete

Comments

Is working now?

davidva gravatar imagedavidva ( 2018-01-22 22:14:40 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-01-22 15:01:13 -0600

ssieb gravatar image

You need to update your kernel and then reboot. The devel package you're installing is for 4.14.13-300, but the akmods is trying to build for your current running kernel which is 4.13.9-300.

edit flag offensive delete link more
0

answered 2018-01-24 17:32:42 -0600

jsd gravatar image

After the last update in Fedora 27 on Wednesday, January 24, 2018 wifi stopped working so I opened the terminal, first I tried to re install

# dnf install kernel-devel broadcom-wl akmod-wl akmods but the system informs that it is already installed.

Then I ran the following commands # akmods in the first line he warns me that he was fine [OK] but in the second line I got a warning message (I did not capture screen, I only remember that warning) and within that I suggested a command to re-compile a module

/usr/sbin/akmods --force (so I did it as a root)

the process took some seconds and after thata I reboot the system and I ran the comand

#akmods

and I saw I have wifi again.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-01-19 09:16:02 -0600

Seen: 1,835 times

Last updated: Jan 22 '18