Ask Your Question

Crackling noise with XPS 13 9360 (i5-8260)

asked 2018-01-18 14:59:12 -0500

freiform gravatar image

updated 2018-01-31 13:16:48 -0500

Original title: Kernel parameter not working after wake

My Dell XPS 13 9360 (i5-8250U) exhibits noise/crackling. This happens on load or screen changes and can reliably be forced when playing a (muted) video. The Arch wiki suggests a kernel parameter to remedy the situation [1]:


This works directly after boot, until the first sleep/hibernate. After wakeup, the crackling is back until the next reboot, when the kernel parameter apparently takes effect again. I suppose that after wakeup and reinitialization of the i915 module the parameter is not being set?

I am runnig Fedora 27, a quick test with an Ubuntu Live Disc showed the same behaviour, so I guess this is not distro-specific but in fact a general driver problem. Any ideas how to fix this?

update - solved
Solved the problem using a kernel patch that extends a known workaround for this laptop's audio device [2]. I changed the original title as it was misleading. With the patch applied to kernel 4.14, the kernel-parameter mentioned above is no longer required.

The patch should make it into kernel 4.14.15 and 4.15.


edit retag flag offensive close merge delete


link is broken, can you post again, and see if you can fix it?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-01-18 22:39:16 -0500 )edit

I would like to, but the link isn't beeing parsed correctly by markdown. Any ideas?

freiform gravatar imagefreiform ( 2018-01-19 03:34:53 -0500 )edit

Try this it appears that ask fedora is stripping the underscore out of the link, before posting the comment, and if the link is linked from the menu choice, the hash tag is being ignored, so both options are failing to properly process the link. when i click to edit the comment, the underscore show up in the proper location. treating as a code block let the fully resolved link remain intact.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-01-19 08:18:43 -0500 )edit

okay, link mystery solved, so on to the problem. file a bug report with the driver software creator. since the problem is not tied to a particular distro of linux.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-01-19 08:27:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-01-18 22:42:36 -0500

Mordoc gravatar image

I think this has a shot:

The systemd has a process that is invoked during suspend and wake, what if you wrote a script that unloaded the module and parameter before suspend and then reloaded it on wake.

From what I have read here:, you could put a script in "usr/lib/systemd/system-sleep/" with this example from the author:

if [ "${1}" == "pre" ]; then
  # Do the thing you want before suspend here, e.g.:
  echo "we are suspending at $(date)..." > /tmp/systemd_suspend_test
elif [ "${1}" == "post" ]; then
  # Do the thing you want after resume here, e.g.:
  echo "...and we are back from $(date)" >> /tmp/systemd_suspend_test

Hope this helps...

edit flag offensive delete link more


Unfortunately I cannot unload a module that is in use. But maybe there is a possibility to (re-)set the parameter while the module is running.

On the other hand, /sys/module/i915/parameters/ tells me that enable_guc_loading is still set after waking up.

freiform gravatar imagefreiform ( 2018-01-19 03:55:32 -0500 )edit

Question Tools

1 follower


Asked: 2018-01-18 14:53:50 -0500

Seen: 689 times

Last updated: Jan 31 '18