Ask Your Question
0

REMI'S PHP WORKSTATION

asked 2018-01-13 04:55:11 -0500

bionan2017 gravatar image

I followed the instructions shown in My PHP Workstation from Remi's blog ( https://blog.remirepo.net/post/2016/0... )

  • I installed PHP versions 7.2 and 5.4 from the Remi repository

  • I change the FPM pool configuration and specific port for each version (file www.conf in /etc/opt/remi/php72/php-fpm.d Strangely the php54 folder does not appear in / etc / opt / remi. just made the changes to php72)

in /etc/opt/remi/php72/php-fpm.d/www.conf:

listen = 127.0.0.1:9072
pm = ondemand
  • SELinux is disabled.

  • I enable the service for each version:

systemctl start php72-php-fpm
systemctl enable php72-php-fpm
systemctl start php54-php-fpm
systemctl enable php54-php-fpm
  • I made the suggested changes to Apache:

In / etc / hosts

127.0.0.1 php72scl php54scl

In httpd / conf.d I created the multiple.conf file:

<Directory "/ home / * / public_html">
    AllowOverride FileInfo AuthConfig Limit Indexes
    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    Require method GET POST OPTIONS
</ Directory>

<VirtualHost *: 80>
    ServerName php72scl
    <FilesMatch \ .php $>
        SetHandler "proxy: fcgi: //127.0.0.1: 9072"
    </ FilesMatch>
</ VirtualHost>


<VirtualHost *: 80>
    ServerName php54scl
    <FilesMatch \ .php $>
        SetHandler "proxy: fcgi: //127.0.0.1: 9054"
    </ FilesMatch>
</ VirtualHost>

I activated version 72:

module load php72

When I try

http: // php72scl / ~ john: ok, it works

http: //php72scl/~john/index.html: ok, it works

http: //php72scl/~john/test.php: not work. 503 Service Unavailable

Any sugestion?

Thanks for any help.

edit retag flag offensive close merge delete

Comments

Have a look at https://airbrake.io/blog/http-errors/... and see if the logs, e.g., error or https have any more details.

robbiethek gravatar imagerobbiethek ( 2018-01-13 06:58:25 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-01-15 02:17:36 -0500

remi gravatar image

updated 2018-01-15 02:19:07 -0500

For old SCLs (php54, php55), configuration is in /opt/remi/phpxx/root/etc.

Notice: these SCLs are no more available for Fedora >= 26 (only PHP 5.6+, as old PHP versions are not compatible with OpenSSL 1.1, even 5.6 require some big patch)

I cannot reproduce your issue. 503 usually mean that FPM is not running or that the socket is not readable.

edit flag offensive delete link more

Comments

Thank you!

bionan2017 gravatar imagebionan2017 ( 2018-01-17 02:56:57 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2018-01-13 04:55:11 -0500

Seen: 178 times

Last updated: Jan 15 '18