Ask Your Question

Fedora 27 freezing with Nvidia proprietary drivers

asked 2018-01-10 18:49:35 -0500

theterminator gravatar image


I’m trying to replace Windows with Fedora and am unsuccessful.

The initial installation works fine, it’s after I install the Nvidia proprietary drivers that I run into problems. Fedora will either freeze at the login screen or shortly after logging in.

I have attempted multiple reinstalls with installing the Nvidia drivers first to ensure that this is the cause of the problem.

I have tried

  • Following the steps on if not true then false
  • Installing drivers from RPMfusion
  • Installing drivers from negativo17

My system specs are

  • Intel i7 6700k
  • Asus VIII Hero Alpha
  • Asus Geforce 1080 O8G

I’ve been trying to find a solution to my problem and some say to change the DE. However, I really like using gnome and it’s layout. Also, other solutions say to stick to the nouveau drivers. As much as I would like to use the open source drivers, it doesn’t give me quite the performance I need.

Has anyone also encountered this problem? Is there any solution to this issue?

edit retag flag offensive close merge delete


Is there a system crash log I can look at to see what happens just before my computer freezes?

theterminator gravatar imagetheterminator ( 2018-01-11 10:37:25 -0500 )edit
christianbueno gravatar imagechristianbueno ( 2018-03-24 14:51:32 -0500 )edit

4 Answers

Sort by » oldest newest most voted

answered 2018-01-16 03:31:12 -0500

theterminator gravatar image

So after many days & reinstalls I found the cause of the problem.

The issue was caused when PowerMizer changes performance levels and under clocks the card. I changed the Preferred Mode to "Prefer Maximum Performance" and now I have no system hangs or freezes.

Thing is, this option resets on reboot so I'll have to look into making a start up script which solves this.

This fix also solves another issue I came across where the screen would freeze for a few seconds, then resume but I can only move the mouse but can't actually do anything.

I assume not all Nvidia 1080 cards have this issue. My specific card is an Asus Geforce GTX 1080 O8G.

Hopefully this fix will save someone else a lot of time and effort.

edit flag offensive delete link more


this has helped me with my Dell XPS 15 (1050Ti), thanks so much!

shingekinolinus gravatar imageshingekinolinus ( 2018-10-28 01:24:08 -0500 )edit

answered 2018-01-11 06:39:31 -0500

Orriginal gravatar image

You may find this link Very helpful - It walks you through everything from listing your correct card to finding the drivers . Also, in the search bar above, type in Nvidia and see the list f previous questions that come up.. some of them may well help you For Nvidia drivers - Got o

type " /sbin/lspci | grep VGA " in terminal to get model number follow instructions

Don't forget to do a " sudo dnf update " afterwards just to be sure, then reboot

edit flag offensive delete link more


I’ve just done a fresh install and still no luck. I followed the steps for “Current GeForce/Quadro/Tesla”.

After installing the drivers and rebooting, the login screen becomes very laggy, maybe 1 frame per second. It can be somewhat fixed by reinstalling a certain version of mutter which gives me about 20 frames per second.

If I log into “Gnome” it still gives me 20 frames per second which is unusable. If I log into “Gnome on Xorg” it runs smoothly. However, maybe after 5 minutes of usage, now the whole desktop freezes but I can still move my mouse. Nothing is clickable or movable though

theterminator gravatar imagetheterminator ( 2018-01-11 10:35:25 -0500 )edit

what was the output when you typed " /sbin/lspci | grep VGA "

Orriginal gravatar imageOrriginal ( 2018-01-12 03:31:58 -0500 )edit

answered 2018-01-11 10:03:23 -0500

Hggfs gravatar image

Did you tried disabling Wayland?

# vim /etc/gdm/custom.conf

Put WaylandEnable=false

Wayland doesnt works with nvidia drivers, i think. Im using xfce, so no wayland anyway.

edit flag offensive delete link more


I tried doing that with the drivers from negativo17 and after I log in I get a blank black screen.

theterminator gravatar imagetheterminator ( 2018-01-11 10:36:36 -0500 )edit

answered 2018-01-11 07:38:39 -0500

Chambers3000 gravatar image

No need to try a different DE. I can confirm Gnome is working. I have installed Nvidia driver both ways with native driver and Negativo repository.

edit flag offensive delete link more


What are your system specs?

theterminator gravatar imagetheterminator ( 2018-01-11 10:35:52 -0500 )edit

Question Tools

1 follower


Asked: 2018-01-10 18:49:35 -0500

Seen: 3,610 times

Last updated: Jan 11 '18