[Solved] F27 Gnome (esp. Wayland) very slow after last update (4.14.11)

asked 2018-01-08 06:48:16 -0500

Onox gravatar image

updated 2018-01-09 11:33:43 -0500


Last Thursday, I worked a while on Fedora 27 (this is a dual boot system with Windows 10), everything was working fine, and I updated the system with the dnf upgrade command, but didn't reboot at the time, and then I turned off the computer and I haven't booted on Fedora since this morning, where I immediately noticed that everything was extremely sluggish, even on the login screen. The CPU usage is like 90% percent on every core of my AMD Ryzen 1700X and graphically, the Gnome desktop is very slow. My dnf history is as follows:

ID | Command line | Date et time | Action(s) | Modified

 9 | update                   | 2018-01-04 17:58 | E, I, U        |   38 EE
 8 | install code             | 2017-12-30 16:06 | Install        |    2   
 7 | update                   | 2017-12-30 16:01 | I, U           |  161 EE
 6 | install https://download | 2017-12-30 15:54 | Install        |    1   
 5 | install https://download | 2017-12-30 15:53 | Install        |    1   
 4 | install gnome-tweak-tool | 2017-12-30 15:39 | Install        |    2   
 3 | install chrome-gnome-she | 2017-12-30 15:37 | Install        |    2   
 2 | upgrade                  | 2017-12-19 13:59 | I, O, U        |  559 E<
 1 |                          | 2017-11-05 08:29 | Install        | 1568 >E

The installed kernels that I have now:

  • 4.14.11
  • 4.14.8
  • 4.14.6

It was update #7 that installed version 4.14.8, and with that version everything worked fine before update #9, which installed 4.14.11. But now, if I select 4.14.8 on the GRUB boot menu, I have the same huge performance issue. On the login screen, if I choose GNOME on Xorg, then it works much better, but it's still sluggish, and CPU usage is higher than before on idle.

Finally, if I boot on 4.14.6, performance is normal and the Gnome desktop is very smooth, as it was before update #9. So that means that it's probably not the kernel update alone that causes this issue, otherwise it should still work fine with 4.14.8, as it used to before update #9, right?

My graphics card is an nvidia GeForce 1070, and I haven't tried installing the proprietary driver yet.

Also, I cannot rollback my updates, because if I do dnf history rollback 8, I get:

No package appstream-data-0:27-7.fc27.noarch available.
Error : A transaction cannot be undone

So it seems that for now I can work by booting on 4.14.6, but what steps should I take to try to solve this problem? Not sure if this problem is related to the Meltdown patch. Thanks in advance

edit retag flag offensive close merge delete


You mentioned that your cpu shows 90% utilization. It might be helpful to know what program is using so many cpu cycles. You can use the top command to view that information. Also, GNOME performance is not impacted in a meaningful way by the recent security patches.

darakus gravatar imagedarakus ( 2018-01-08 18:14:06 -0500 )edit

Thank you for your answer! I've just edited the title to say that my problem is solved… and I didn’t have anything to do about it. After a couple of additional reboots (which I had already done to try the different kernel versions), everything was back to normal. I had opened the system monitor to check which process was using so much CPU, which was gnome-shell. I have no idea what happened and I am sorry for the now useless post.

Onox gravatar imageOnox ( 2018-01-09 11:40:22 -0500 )edit

Hi that's not that useless I have the same problem. I'm currently on 4.13.9 no problem but I have an issue with the latest kernel. My graphic card is Geforce 1050Ti I had problems with nouveau so I installed proprietary driver through rpmfusion (It works great). Same symptoms login super slow. Without touching anything gnome-shell is up 20% cpu usage (i5 7600). touching the mouse and it climbs up to 300%...

nevertoolate gravatar imagenevertoolate ( 2018-02-04 07:35:40 -0500 )edit

Experiencing the same with my GTX1070 card. I've found that if I boot into my windows partition first, then do a soft reboot into the Fedora partition, then Gnome works fine. Otherwise if I cold-boot into Fedora, then I have the problematic behaviour.

kiren gravatar imagekiren ( 2018-04-25 13:30:51 -0500 )edit