Ask Your Question
0

npm install in fredora 27 throws error

asked 2018-01-04 09:25:24 -0500

afronerd gravatar image

updated 2018-01-05 05:11:17 -0500

FranciscoD_ gravatar image

module.js:538 throw err; ^

Error: Cannot find module 'update-notifier'
    at Function.Module._resolveFilename (module.js:536:15)
    at Function.Module._load (module.js:466:25)
    at Module.require (module.js:579:17)
    at require (internal/module.js:11:18)
    at /usr/lib/node_modules/npm/bin/npm-cli.js:29:19
    at Object.<anonymous> (/usr/lib/node_modules/npm/bin/npm-cli.js:92:3)
    at Module._compile (module.js:635:30)
    at Object.Module._extensions..js (module.js:646:10)
    at Module.load (module.js:554:32)
    at tryModuleLoad (module.js:497:12)

please assist

edit retag flag offensive close merge delete

Comments

Hi, could you please post the full command? (here or pastebin) Cheers

casep gravatar imagecasep ( 2018-01-08 05:21:03 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-03-02 10:58:20 -0500

FedUser1975 gravatar image

I have the same problem. Npm won't work anymore after running the recommended command line task "npm i -g npm".

Error: Cannot find module 'update-notifier'
    at Function.Module._resolveFilename (module.js:538:15)
    at Function.Module._load (module.js:468:25)
    at Module.require (module.js:587:17)
    at require (internal/module.js:11:18)
    at /usr/lib/node_modules/npm/bin/npm-cli.js:29:19
    at Object.<anonymous> (/usr/lib/node_modules/npm/bin/npm-cli.js:92:3)
    at Module._compile (module.js:643:30)
    at Object.Module._extensions..js (module.js:654:10)
    at Module.load (module.js:556:32)
    at tryModuleLoad (module.js:499:12)

So, now my project is broken. What can i do?

edit flag offensive delete link more
0

answered 2018-03-09 15:36:27 -0500

what i did was removing npm, nodejs and then install again, something goes broken when auto updating npm with:

npm i -g npm

better stay away of updating npm by itself and stay with current fedora27 version updates.

if you need a specific node/npm version go with docker https://developer.fedoraproject.org/t...

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-01-04 09:25:24 -0500

Seen: 503 times

Last updated: Mar 02 '18