printer installation: issue with execution of filter

asked 2018-01-01 11:35:37 -0500

ragde gravatar image

updated 2018-01-04 06:33:58 -0500

Hi there,

I have a problem connecting my printer to fedora27.

Obviously, there is some issue with executing the filter, or is it already due to this "insecure" message?

Unfortunately, I'm not able to produce more verbose logging information, see /var/log/messages below. I already checked the "Save debugging information for troubleshooting" in the cups interface, but I do not find additional logs, e.g. the precise line executed to possibly execute by hand in a shell. I don't know how I may debug.

Any help, recommendation, or assistance would be welcome. Thanks in advance

from /var/log/messages:

Jan  1 17:54:18 localhost cupsd[848]: [Client 123] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=6364, file=17)
Jan  1 17:54:18 localhost cupsd[848]: [Job ???] Request file type is application/vnd.cups-pdf-banner.
Jan  1 17:54:18 localhost cupsd[848]: Adding start banner page "none".
Jan  1 17:54:18 localhost cupsd[848]: Adding end banner page "none".
Jan  1 17:54:18 localhost cupsd[848]: File of type application/vnd.cups-pdf-banner queued by "root".
Jan  1 17:54:18 localhost cupsd[848]: Queued on "Dell_V505" by "root".
Jan  1 17:54:18 localhost cupsd[848]: Started filter /usr/lib/cups/filter/bannertopdf (PID 6365)
Jan  1 17:54:18 localhost cupsd[848]: Started filter /usr/lib/cups/filter/pdftopdf (PID 6366)
Jan  1 17:54:18 localhost cupsd[848]: Started filter /usr/lib/cups/filter/gstoraster (PID 6367)
Jan  1 17:54:18 localhost cupsd[848]: Dell_V505: File "/usr/local/dell/dldw/bin/printdriver" has insecure permissions (0100775/uid=0/gid=1).
Jan  1 17:54:18 localhost cupsd[848]: Unable to start filter "/usr/local/dell/dldw/bin/printdriver" - Success.
Jan  1 17:54:18 localhost cupsd[848]: Stopping job because the scheduler could not execute a filter.
Jan  1 17:54:18 localhost cupsd[848]: REQUEST localhost - - "POST /printers/Dell_V505 HTTP/1.1" 200 414 Print-Job successful-ok

Hi there, Panther and fcomida,

Thanks for your notification. Trying to clarify by detailing what has been done so far.

  1. Installation of dell driver R201206 by "dnf install dell-v505-driver-1.0-1.i386.rpm"
  2. print driver is installed to "/usr/local/dell/dldw/"
  3. status of printdriver "-rwxr-xr-x. 1 root bin 58954 Sep 19 2008 printdriver"
  4. Going to cusp "http://localhost:631/admin"
  5. Adding the usb printer in list "Dell V505", connection "Connection: usb://Dell/V505?serial=8CRN2G1&interface=1"
  6. Providing additional ppd file dlV505.ppd from "/usr/local/dell/dldw/etc"
  7. Printer has been set successfully, ...

Finally, printing the test page produces the message in /var/log/messages as outlined above.

edit retag flag offensive close merge delete

Comments

Can you clarify your question ? What are you trying to install, how did you install it, how it the printer attached, how did you try to configure your printer, and what problem are you having exactly.

Panther gravatar imagePanther ( 2018-01-01 13:36:46 -0500 )edit

chmod 755 /usr/local/dell/dldw/bin/printdriver

fcomida gravatar imagefcomida ( 2018-01-01 13:46:12 -0500 )edit

I also typed

/usr/local/dell/dldw/bin/printdriver

directly in the shell, which gives:

Usage: /usr/local/dell/dldw/bin/printdriver job-id user title copies options [file]

but I do not know how to debug further, because I'm not aware what command the cupsd finally issues.

ragde gravatar imageragde ( 2018-01-03 14:13:33 -0500 )edit

@ragde have you changed permissions as suggested?

fcomida gravatar imagefcomida ( 2018-01-04 07:04:43 -0500 )edit

Just to be sure, do you have the cups-filters package installed?

scottro gravatar imagescottro ( 2018-01-04 08:22:48 -0500 )edit