Ask Your Question

How to turn off automount in Fedora 27?

asked 2017-12-28 07:34:09 -0500

billwilliams gravatar image


How can I turn off automount in Fedora 27 permanently?

Thank you,


edit retag flag offensive close merge delete


This question could be closed as duplicate of:

florian gravatar imageflorian ( 2017-12-28 15:35:23 -0500 )edit

Hi Florian, thanks for the link. However I have the issue when running command line also (without gdm for example). So I guess there is a systemd issue also, not only gnome? Thanks, Bill

billwilliams gravatar imagebillwilliams ( 2018-01-04 23:36:40 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2017-12-28 15:34:57 -0500

florian gravatar image

Without dconf-editor, from a terminal run:

gsettings get automount to read the current value.

To change it to false, run gsettings set automount false

edit flag offensive delete link more


@florian, thank you, this seems to be all that was needed.

billwilliams gravatar imagebillwilliams ( 2018-01-17 14:46:18 -0500 )edit

answered 2017-12-28 13:47:09 -0500

SteveEbey73701 gravatar image

dconf-editor and goto org > gnome > desktop > media-handling and uncheck auto-mount. if you use a different desktop, put the name of the desktop in place of gnome.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-12-28 07:34:09 -0500

Seen: 1,619 times

Last updated: Dec 28 '17