Ask Your Question
0

Fedora 27 - slow boot with systemd.udev-settle.service

asked 2017-12-20 12:05:20 -0500

mswal2846 gravatar image

I am experience a very slow boot on my Fedora 27 Thinkpad x230 with a 1T SSD hard drive.

A "systemd-analyze blame" shows:

$ systemd-analyze blame
  2min 843ms lvm2-monitor.service
  2min 696ms systemd-udev-settle.service
     12.752s NetworkManager-wait-online.service
      7.397s dracut-initqueue.service
      6.921s systemd-cryptsetup@luks\x2d9ae54b21\x2dfdb9\x2d4da7\x2d9809\x2d
      5.578s plymouth-quit-wait.service
      3.098s network.service
      1.742s lvm2-pvscan@253:0.service
      1.717s dnf-makecache.service
      1.163s firewalld.service
       889ms fwupd.service
       704ms initrd-switch-root.service
       701ms vboxdrv.service
       628ms dev-mapper-fedora\x2droot.device
       591ms cups.service
       455ms systemd-rfkill.service
       425ms libvirtd.service
       393ms accounts-daemon.service
       345ms systemd-fsck-root.service
       338ms chronyd.service
       308ms var-lib-nfs-rpc_pipefs.mount
       290ms systemd-logind.service

In researching this, I found to provide this information also for the systemd-modules-load.service item:

[mswallow@localhost ~]$ sudo systemctl restart systemd-modules-load.service [sudo] password for mswallow: [mswallow@localhost ~]$ sudo systemctl status systemd-modules-load.service ● systemd-modules-load.service - Load Kernel Modules Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; Active: inactive (dead) Condition: start condition failed at Wed 2017-12-20 12:56:23 EST; 3s ago ├─ ConditionDirectoryNotEmpty=|/lib/modules-load.d was not met ├─ ConditionDirectoryNotEmpty=|/usr/lib/modules-load.d was not met ├─ ConditionDirectoryNotEmpty=|/usr/local/lib/modules-load.d was not ├─ ConditionDirectoryNotEmpty=|/etc/modules-load.d was not met ├─ ConditionDirectoryNotEmpty=|/run/modules-load.d was not met ├─ ConditionKernelCommandLine=|modules-load was not met └─ ConditionKernelCommandLine=|rd.modules-load was not met Docs: man:systemd-modules-load.service(8) man:modules-load.d(5)

So how do I debug why the lvm2-monitor.service and the systemd-udev-settle.service are taking so long?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-12-20 13:18:18 -0500

sideburns gravatar image

A web search took me to an old question here from just over a year ago. It turns out that systemd-udev-settle.service is needed if and only if you're using LVM, which is the Fedora default. If you're sure you're not using it, mask that one service and reboot to see what happens. If you are, we'll have to work on why it's taking so long.

edit flag offensive delete link more

Comments

Well, I executed "sudo systemctl mask systemd-udev-settle.service" and it fixed the problem. The system booted up in seconds. Is there something more I should do with this? Something I should uninstall or set more permanently?

mswal2846 gravatar imagemswal2846 ( 2017-12-20 17:40:30 -0500 )edit

No, you've done all that you need. Disabling a service stops it from starting on its own, but something else can bring it in. Masking makes it impossible to start the service until you unmask it, so there's no need to uninstall it. Besides, removing it might also remove other things that you need.

sideburns gravatar imagesideburns ( 2017-12-20 18:10:30 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-12-20 12:05:20 -0500

Seen: 2,083 times

Last updated: Dec 20 '17