Ask Your Question

Delay when changing volume

asked 2017-12-12 08:37:05 -0500

christianbueno gravatar image

updated 2018-02-20 08:53:32 -0500

In fedora 27 workstation (gnome) when i type the up or down multimedia key , the pop-up volume icon is displayed correctly instantly , the icon sound effect too, but the volume take 1.9 second to increment or reduce, it is very perceive by ears.

It is not the icon sound effect just in case, you coul x example play a song in spotify and type the up/down key then will realize the delay. I have tested that in fedora kde plasma and there is no problem, up or down the volume took action immediately , yesterday tested that in fedora mate-compiz too and there is no problem too.

Again ,the problem is with an delay for the system take up or down the volume, when you type the key you can perceive by the ears that the reduce or increment take action in 1.9 second aproximately of delay.

Update: It seems only a problem with spotify desktop application

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-12-12 19:34:53 -0500

christianbueno gravatar image

updated 2017-12-12 20:24:09 -0500

the problems seems to be with spotify desktop application, I installed the app by flatpak with flathub remote. And you can reproduce that by open only the spotify desktop app.
It is interesting because, when you play a music cd with Rhythmbox , stop the music, then run spotify desktop app, you will not find problems about delay in volume.

Here the solution source here, thanks to plasma-cx user

- change to root user

su -
- Type the root password
- Edit /etc/pulse/daemon.conf file with your preferred text editor , vim is my option, learn first how to use it if you never have used it.
Instead of edit I prefer to add a new line following the line "enable-deferred-volume" to define a new value , here the differences between semicolon(;) and number sign(#)

; enable-deferred-volume = yes
enable-deferred-volume = no
- Save the file
- Change to normal user
- Restart the PulseAudio daemon

pulseaudio -k
pulseaudio --restart
- If spotify was open , close and open again the application.

edit flag offensive delete link more


Please mark this answer as correct instead of adding 'Solved' to the title of your question.

florian gravatar imageflorian ( 2017-12-12 22:54:47 -0500 )edit

Question Tools

1 follower


Asked: 2017-12-12 08:37:05 -0500

Seen: 278 times

Last updated: Feb 20 '18