Ask Your Question

Sound issues with Fedora 27

asked 2017-11-25 01:43:17 -0500

dsax7 gravatar image

I recently switched from Windows 10 to Fedora 27 and it has been going wonderful so far, however, I noticed some crackling, popping sounds when watching videos on the Internet.

I ran --no-upload, but as I am new to the Linux world, this does not give me much information. The content of the file is relatively long so I will not include the whole thing and if someone can point out the more important parts, I can include them. Moreover, this does not occur every time and I did try with a different browser (Chrome and Firefox both have the same result).

As I already mentioned, I am relatively new to Linux, so I do not want to configure/fix things just by reading guides/tutorials on the Internet, without understanding what I am actually doing.

edit retag flag offensive close merge delete


Is it built in sound or an external USB or Firewire interface? Which model?

David-LDA gravatar imageDavid-LDA ( 2017-11-25 04:11:47 -0500 )edit

Build in sound. The laptop is Lenovo Thinkpad x230 and the sound card should be 00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04).

dsax7 gravatar imagedsax7 ( 2017-11-25 04:36:50 -0500 )edit

I have been using Fedora since version 24, and I have to say that Fedora 27 has had the worst problems of all of them. The others were rock solid. Gnome shell crashes and Pulse Audio keeps loosing connection with my external USB sound interface.

I think there are problems with Fedora 27 as it is so new and they changed a lot of stuff under the hood. I would recommend you wait anther couple of weeks and keep on doing sudo dnf update every few days. I predict it is going to fix itself with some updates! Well done dumping Win10, don't worry, your sound will be fine soon!

David-LDA gravatar imageDavid-LDA ( 2017-11-25 10:46:31 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2017-12-25 01:22:35 -0500

dawciobiel gravatar image

I got problem with no sound after upgrade fedora 22 -> 23,24,25,26, -> 27.

# --no-upload

My /tmp/alsa-info.txt.Pd6gryr1eo content:

!!ALSA Information Script v 0.4.64

!!Script ran on: Mon Dec 25 07:13:39 UTC 2017

!!Linux Distribution

Fedora release 27 (Twenty Seven) NAME=Fedora ID=fedora PRETTY_NAME="Fedora 27 (Twenty Seven)" CPE_NAME="cpe:/o:fedoraproject:fedora:27" HOME_URL="" SUPPORT_URL="" BUG_REPORT_URL="" REDHAT_BUGZILLA_PRODUCT="Fedora" REDHAT_BUGZILLA_PRODUCT_VERSION=27 REDHAT_SUPPORT_PRODUCT="Fedora" REDHAT_SUPPORT_PRODUCT_VERSION=27 PRIVACY_POLICY_URL="" Fedora release 27 (Twenty Seven) Fedora release 27 (Twenty Seven)

!!DMI Information

Manufacturer:      To Be Filled By O.E.M.
Product Name:      To Be Filled By O.E.M.
Product Version:   To Be Filled By O.E.M.
Firmware Version:  P1.60
Board Vendor:      ASRock
Board Name:        990FX Killer

!!ACPI Device Status Information

/sys/bus/acpi/devices/PNP0103:00/status      15
/sys/bus/acpi/devices/PNP0501:00/status      15
/sys/bus/acpi/devices/PNP0A03:00/status      15
/sys/bus/acpi/devices/PNP0C01:00/status      15
/sys/bus/acpi/devices/PNP0C02:00/status      15
/sys/bus/acpi/devices/PNP0C0C:00/status      11
/sys/bus/acpi/devices/PNP0C0F:00/status      11
/sys/bus/acpi/devices/PNP0C0F:01/status      11
/sys/bus/acpi/devices/PNP0C0F:02/status      11
/sys/bus/acpi/devices/PNP0C0F:03/status      11
/sys/bus/acpi/devices/PNP0C0F:04/status      11
/sys/bus/acpi/devices/PNP0C0F:05/status      11
/sys/bus/acpi/devices/PNP0C0F:06/status      11
/sys/bus/acpi/devices/PNP0C0F:07/status      11

!!Kernel Information

Kernel release:    4.14.8-300.fc27.x86_64
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         x86_64
SMP Enabled:       Yes

!!ALSA Version

Driver version:     k4.14.8-300.fc27.x86_64
Library version:    
Utilities version:  1.1.5

!!Loaded ALSA modules


!!Sound Servers on this system

      Installed - Yes (/bin/pulseaudio)
      Running - Yes

      Installed - Yes (/bin/jackd)
      Running - Yes

!!Soundcards recognised by ALSA

 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe300000 irq 16
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe080000 irq 30

!!PCI Soundcards installed in the system

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)


!!ALSA/HDA dmesg

[    3.269860] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    3.274810] snd_hda_intel 0000:01:00.1: Disabling MSI
[    3.274823] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    3.287624] snd_hda_codec_realtek hdaudioC0D0: ALC1150: SKU not ready 0x00000000
[    3.288097] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1150: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line
[    3.288098] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.288100] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    3.288101] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    3.288102] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
[    3.288103] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    3.288104] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[    3 ...
edit flag offensive delete link more

answered 2017-11-26 02:43:46 -0500

workman729 gravatar image

Yes, Intel devices old habit bug. It's not issue the alsa or pulse sound.

I think driver issues, the depend on sound duplication option in kernel activity. Some people talk about fixed the kernel update and kernel compile.

I don't saying no more, i don't have experience intel device. So, this option help your problem. (some case)

  1. Create a copy of the configuration files to your user's pulse folder: $ cp /etc/pulse/* ~/.pulse/

  2. Edit ~/.pulse/, do a search for "tsched=0" and change to "tsched=1".

  3. (Optional). Edit ~/.pulse/daemon.conf and comment the "resample-method", "default-fragments" and "default-fragments-msec" lines, like so:

; resample-method = speex-float-1 ; default-fragments = 8 ; default-fragment-size-msec = 10

Good Luck.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-11-25 01:43:17 -0500

Seen: 4,549 times

Last updated: Nov 26 '17