Ask Your Question

tracker-store never finishes

asked 2017-11-23 01:43:30 -0500

TheSpanishInquisition gravatar image

updated 2017-11-23 01:45:21 -0500

Hi, I've updated to f27 a couple of days ago and tracker-store just keeps my cpu at high load without ever finishing. I let the computer work over night several times and it must have racked up at least 24 hours of time with no signs of stopping. My /home directory is about 300GB but I've used .trackerignore files to blacklist most of it.

My gsettings are:
org.freedesktop.Tracker.Miner.Files initial-sleep 15
org.freedesktop.Tracker.Miner.Files index-optical-discs false
org.freedesktop.Tracker.Miner.Files index-recursive-directories ['&DESKTOP', '&DOCUMENTS', '&MUSIC', '&PICTURES']
org.freedesktop.Tracker.Miner.Files enable-monitors true
org.freedesktop.Tracker.Miner.Files index-on-battery false
org.freedesktop.Tracker.Miner.Files sched-idle 'first-index'
org.freedesktop.Tracker.Miner.Files ignored-directories ['po', 'CVS', 'core-dumps', 'lost+found']
org.freedesktop.Tracker.Miner.Files crawling-interval -1
org.freedesktop.Tracker.Miner.Files ignored-files ['~', '.o', '.la', '.lo', '.loT', '.in', '.csproj', '.m4', '.rej', '.gmo', '.orig', '.pc', '.omf', '.aux', '.tmp', '.po', '.vmdk', '.vm', '.nvram', '.part', '.rcore', '.lzo', 'autom4te', 'conftest', 'confstat', 'Makefile', 'SCCS', '', 'libtool', 'config.status', 'confdefs.h', 'configure', '##', '~$.doc?', '~$.dot?', '~$.xls?', '~$.xlt?', '~$.xlam', '~$.ppt?', '~$.pot?', '~$.ppam', '~$.ppsm', '~$.ppsx', '~$.vsd?', '~$.vss?', '~$.vst?', '.desktop', '*.directory']
org.freedesktop.Tracker.Miner.Files ignored-directories-with-content ['.trackerignore', '.git']
org.freedesktop.Tracker.Miner.Files index-removable-devices false
org.freedesktop.Tracker.Miner.Files removable-days-threshold 3
org.freedesktop.Tracker.Miner.Files index-single-directories ['$HOME']
org.freedesktop.Tracker.Miner.Files low-disk-space-limit -1
org.freedesktop.Tracker.Miner.Files throttle 0
org.freedesktop.Tracker.Miner.Files verbosity 'errors'
org.freedesktop.Tracker.Miner.Files enable-writeback true
org.freedesktop.Tracker.Miner.Files index-on-battery-first-time true
org.freedesktop.Tracker.Store verbosity 'errors'
org.freedesktop.Tracker.Store graphupdated-delay 1000
org.freedesktop.Tracker.DB journal-rotate-destination ''
org.freedesktop.Tracker.DB journal-chunk-size 50
org.freedesktop.Tracker.Extract max-media-art-width 0
org.freedesktop.Tracker.Extract verbosity 'errors'
org.freedesktop.Tracker.Extract wait-for-miner-fs false
org.freedesktop.Tracker.Extract max-bytes 1048576
org.freedesktop.Tracker.Extract sched-idle 'first-index'

Thanks in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-11-28 07:14:10 -0500

I had the same problem, removing $HOME/.local/share/tracker/ and $HOME/.cache/tracker/ worked for me. You may want to logout first (I did that, tracker starts on user login, stopped otherwise) and remove the two directories via console.


edit flag offensive delete link more


It worked for me too, thanks a lot.

TheSpanishInquisition gravatar imageTheSpanishInquisition ( 2017-12-03 11:29:51 -0500 )edit

Question Tools

1 follower


Asked: 2017-11-23 01:43:30 -0500

Seen: 972 times

Last updated: Nov 23 '17