Cannot add correct resolution using Mate

asked 2017-11-19 11:26:27 -0500

jpill gravatar image

updated 2017-11-24 08:53:15 -0500

I have Mate Desktop in my Fedora 26, recently i connected an old projector. Mi display has a resolution of 1366x768 with name VGA1, the projector's resolution is 864x486 with name LSVD1

When i unpluged the projector the screens inverted, so the laptop display has the name LVSD1 with maximum resolution of 864x486, when i plug the projector it takes the name VGA1 with resolution 1366x768.

The file Xorg.conf has the following configuration:

cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 384.90  (buildmeister@swio-display-x86-rhel47-05)  Tue Sep 19 18:13:03 PDT 2017

Section "ServerLayout"
    Identifier     "Layout0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "IntelGPU"
    Driver         "intel"
    VendorName     "Intel Corporation"
    BusID          "PCI:00:02:0"

Section "Screen"
    Identifier     "Default Screen"
    Device         "IntelGPU"
    Monitor        "Monitor0"

With xandr i can set the mode but cannot assign to the screen of the laptop (LVSD1)

$ xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
$ xrandr --addmode LVDS1 "1368x768_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  139 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  37
  Current serial number in output stream:  38

If i switch to Gnome 3 the resolution keeps fine, but i really don't like Gnome 3.

So, how can i fix this?

edit retag flag offensive close merge delete


I realized that LVSD1 is the correct ID for the display. I updated to Fedora 27 and the problem persist, i really don't know what to do know.

jpill gravatar imagejpill ( 2017-11-23 21:49:35 -0500 )edit