Ask Your Question
0

Cannot upgrade to 27

asked 2017-11-17 03:28:12 -0500

gtomas gravatar image

updated 2017-11-17 03:53:56 -0500

masteroman gravatar image

Hi,

I cannot seem to upgrade because of a broken package, which is not installed. I have done the --refresh upgrade. Here's the output of

sudo dnf system-upgrade download --releasever=27 --allowerasing --skip-broken

Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y 
Failed to synchronize cache for repo 'threeed-variety', disabling.
Failed to synchronize cache for repo 'insync', disabling. 
Failed to synchronize cache for repo 'postinstallerf', disabling. 
Failed to synchronize cache for repo 'postinstallerf-updates', disabling.
Last metadata expiration check:
0:00:00 ago on Fri 17 Nov 2017 10:26:06 CET. 
Error: Problem: package vlc-core-1:3.0.0-20.20170624git1601852.fc26.x86_64 requires libprotobuf-lite.so.12()(64bit), but none of the providers can be installed
- protobuf-lite-3.2.0-4.fc26.x86_64 does not belong to a distupgrade repository
- problem with installed package vlc-core-1:3.0.0-20.20170624git1601852.fc26.x86_64

How do I remove the installed packages?

sudo dnf remove vlc* does not work

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-11-17 03:58:48 -0500

masteroman gravatar image

Fixed formatting a bit since it was unreadable.

Errors regarding "failed to synchronize cache for repo" as I can see are caused by third party repositories that aren't updated or are not reachable for some other reason. Repositories being:

  • insync repository (likely google drive sync client or something like that)
  • threeed-variety
  • postinstallerf (easy post-install fedora configuration?)

In order to resolve those issues it is best to disable those repositories.

As for VLC, it is complaining that it requires updated library but one isn't available. Find exact package name:

[ivan@kirk ~]$ rpm -q vlc
vlc-3.0.0-0.37.git20171009.fc26.x86_64

Then remove it:

sudo dnf remove vlc-3.0.0-0.37.git20171009.fc26.x86_64

Note that your version may be different, so adjust commands to your needs.

After that's finished and you finish the upgrade, I would recommend going with the rpmfusion repository route and installing VLC from there. Those are pretty much always up-to-date.

edit flag offensive delete link more

Comments

Hi! Thank you for the prompt answer. However, VLC does not seem to be installed. There were some issues with that package, I could never get it to work. rpm -q vlc returns "is not installed". Also, how would i disable the repos up there?

gtomas gravatar imagegtomas ( 2017-11-17 04:04:46 -0500 )edit

Can you please give the output of the following command:

rpm -qa | grep -i vlc

As for disabling repositories. They are stored in /etc/yum.repos.d/ directory, find files that provide those repositories (by looking at them) and either change:

enabled=1

to

enabled=0

in those files, or simply delete them/move aside.

masteroman gravatar imagemasteroman ( 2017-11-17 04:08:46 -0500 )edit

The output is vlc-core-3.0.0-20.20170624git1601852.fc26.x86_64 python2-vlc-1.1.2-4.20161001git5d389c7.fc26.noarch

When I try to remove it, I get: No match for argument: vlc-core-3.0.0-20.20170624git1601852.fc26.x86_64 Error: No packages marked for removal

gtomas gravatar imagegtomas ( 2017-11-17 04:44:32 -0500 )edit

So:

sudo dnf remove vlc-core-3.0.0-20.20170624git1601852.fc26.x86_64 vlc-1.1.2-4.20161001git5d389c7.fc26.noarch

doesn't work?

If that's the case, try:

sudo dnf clean all
sudo dnf clean metadata
sudo dnf upgrade --refresh

then try removing those packages again. If that still doesn't work, try removing them manually wiith:

sudo rpm -e vlc-core-3.0.0-20.20170624git1601852.fc26.x86_64 vlc-1.1.2-4.20161001git5d389c7.fc26.noarch
masteroman gravatar imagemasteroman ( 2017-11-17 04:53:56 -0500 )edit

Same thing, did all that, at the end, the final command output:

sudo rpm -e vlc-core-3.0.0-20.20170624git1601852.fc26.x86_64 vlc-1.1.2-4.20161001git5d389c7.fc26.noarch
error: package vlc-1.1.2-4.20161001git5d389c7.fc26.noarch is not installed
gtomas gravatar imagegtomas ( 2017-11-17 05:01:29 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-11-17 03:28:12 -0500

Seen: 322 times

Last updated: Nov 17 '17