Ask Your Question

Fedora27 upgrade doesn't boot into upgrade process

asked 2017-11-15 02:33:04 -0500

francko gravatar image

updated 2017-11-15 08:18:57 -0500

hi there

i've done the actualisation of my F26 successfully with

$ sudo dnf upgrade --refresh

and already installed

$ sudo dnf install dnf-plugin-system-upgrade

downloaded all the files with

$ sudo dnf system-upgrade download --refresh --allowerasing --releasever=27

than the system tells me, it's ready to install F27 with

$ sudo dnf system-upgrade reboot

than the computer reboots, shows the latest F26 kernel and starts to show the white fedora-sign filling up. than it reboots again and shows the login prompt of F26 without upgrading the OS. i tried to read the prompts on the screen and it stops some time with a prompt like "start upgrading while offline" than it continues too fast to read and reboots.

Any idea why the upgrade process could be skipped?

$ uname -a

Linux franks-imac 4.13.12-200.fc26.x86-64 #1 SMP Wed Nov 8 16:47:26 UTC 2017 x86-64 x86-64 x86-64 GNU/Linux

edit retag flag offensive close merge delete


Hi, same exact issue here. I also tried to remove akmods and Virtualbox as suggested somewhere else but no luck. BTW I'm on F26 KDE spin.

ilCerchiari gravatar imageilCerchiari ( 2017-11-15 06:25:41 -0500 )edit

FWIW, I have the same problem. I've tried both the command line upgrade and the graphical upgrade and the same thing happens: the upgrade packages download, the system prompts me to reboot to upgrade, but ultimately boots to Fedora 26. Using the graphical tool, the system rebooted and displayed a message "installing packages." That installation took only a few seconds and then the system again rebooted, this time straight to Fedora 26. I'm running a Dell Inspiron 7548. `[dck@lilith dck]$ uname -a Linux 4.13.12-200.fc26.x86 64 #1 SMP Wed Nov 8 16:47:26 UTC 2017 x8664 x86_64

Darron gravatar imageDarron ( 2017-11-15 11:26:21 -0500 )edit

I had the same problem with DNF. I was able to upgrade the system via the software application ...

EllePi gravatar imageEllePi ( 2017-11-22 13:58:04 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2017-11-15 04:44:32 -0500

Paolo gravatar image

updated 2017-11-15 11:40:42 -0500

Same problem here on Dell Latitude e5550. Any advice is welcome!

$ uname -a
Linux fedora-dell 4.13.12-200.fc26.x86_64 #1 SMP Wed Nov 8 16:47:26 UTC 2017 x86_64 x86_64 x86_64 GNU/Linu x

20171115 UPDATE

Finally i manage to upgrate to Fedora 27. I'm not a big expert so not sure all the passages are mandatory. It worked for me.

  1. Update Fedora distribution dnf upgrade --refresh
  2. First I deleted all third party repositories in /etc/yum.repos.d
  3. As reported here I cleaned Fedora from old packages.
  4. Also I use dnf remove $(dnf repoquery --extras --exclude=kernel,kernel-*) to remove all third party installed packages.
  5. Then clean cached file with sudo dnf clean all and sudo dnf system-upgrade clean. The latter commad deletes all dowloaded packages so that you can start a brand new upgrade.
  6. Upgrade as written in Fedora Magazine

Of course now i have to install again some software as Teamviewer and so...but I'm almost satisfied.

edit flag offensive delete link more


your workaround worked also for me, i just skipped the first point because it's in the upgrade procedure anyway. thanks!

francko gravatar imagefrancko ( 2017-11-16 01:13:06 -0500 )edit

answered 2017-12-06 12:47:02 -0500

dick_tm gravatar image

I had the same problem; In the end it turned out the root partition was to smal, after downloading the new packages for Fedora 27 there was only 2 GB left.

After deleting several directories below /var/cache/PackageKit (from Fedora 24 and 25) I had more than 6 GB left. After which I retried to upgrade; with succes!

$uname -a
Linux localhost.localdomain 4.13.16-302.fc27.x86_64 #1 SMP Thu Nov 30 15:33:36 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
edit flag offensive delete link more

answered 2017-12-27 09:48:41 -0500

gyger gravatar image

I had a similiar problem and found out it was due to a modified /etc/dnf/dnf.conf. So check if you have changed that file.

I did this by copying the file to a backup location:

sudo cp /etc/dnf/dnf.conf /etc/dnf/dnf.conf.backup

then I removed the file and reinstalled the package

sudo dnf reinstall dnf-conf

The content currently of this file is

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-11-15 02:33:04 -0500

Seen: 4,255 times

Last updated: Dec 27 '17