Ask Your Question

Firefox NEVER restores his session after reboot, please why?

asked 2017-11-10 20:24:25 -0500

horizonbrave gravatar image

In the last 12 months, I installed Fedora (and other distros sometimes) like 50ish times! Everytime I configure Firefox to "Show your windows and tabs from last time" but every single time I restart the machine and start Firefox I get the error message "Sorry. We’re having trouble getting your pages back. We are having trouble restoring your last browsing session. Select Restore Session to try again.". Of course if I need to restart or power off my machine it never crosses my mind (and it never should) to close Firefox first.

Thanks for any help, happy to move to Chrome in case :)

edit retag flag offensive close merge delete


This question would be better asked on the Mozilla support site.

tim8723 gravatar imagetim8723 ( 2017-11-11 08:37:37 -0500 )edit

It works just fine if you close Firefox before power off / reboot so the problem is that Firefox doesn't behave well when the system shuts down while it is running. I totally agree that this behavior could be improved but so could your question title.

dreua gravatar imagedreua ( 2017-11-11 11:50:15 -0500 )edit

I noticed this behaviour since Fedora 23.. how's possible the system/gnome is not able to exit the application properly when hitting the power off/resart button in Gnome? Cheers

horizonbrave gravatar imagehorizonbrave ( 2017-11-12 22:00:08 -0500 )edit

@tim8723: I doubt this is a bug in Firefox, but in gnome-shell.

genodeftest gravatar imagegenodeftest ( 2017-11-14 09:18:33 -0500 )edit

2 Answers

Sort by » oldest newest most voted

answered 2017-11-14 09:17:19 -0500

genodeftest gravatar image

There is/was a bug in Gnome which prevented applications from terminating cleanly when shutting down. See also:

So just close all applications before logging out or shutting down your computer. I hope they'll fix this bug.

edit flag offensive delete link more

answered 2018-03-23 09:23:40 -0500

ciscam gravatar image

In about:config, set


to -1 and firefox will resume without the unnecessary prompt.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-11-10 20:24:25 -0500

Seen: 1,075 times

Last updated: Nov 14 '17