Ask Your Question
2

[solved] PXE boot Fedora live dvd results in timeout

asked 2017-11-08 01:12:00 -0500

beta-tester gravatar image

updated 2018-01-17 16:47:18 -0500

hello,

i am absolutely new to Fedora (or Red Hat like distributions) at all...

i have made a project, where i have setted up an PXE server, where i can PXE boot a PC straignt into different linux LiveDVD distributions. for that, i use the ISO files of each linux distribution and mounted them on the PXE server, and made its content available via NFS and TFTP.

i realized, that all (or most) of the debian like linux distribution are working perfect in this way to be able to PXE boot. but all Red Hat like distributions like Fedora i cant get it work to PXE boot this way.

all i get is at PXE boot into Fedora a timeout error message and Fedora wount boot properly, where the debian distributions are mounting the squashfs images sucessfully.

now i hope somebody can help me to get it work.

see attached some log files i could get from the broken Fedora PXE boot.

rdsosreport.txt

and the last part of the error message:

[  191.917825] localhost dracut-initqueue[378]: Warning: dracut-initqueue timeout - starting timeout scripts
[  191.919629] localhost dracut-initqueue[378]: Warning: Could not boot.

it makes no difference if i try to pxe boot Fedora LiveDVD on a virtual machine or on a real PC with real hardware.

here the link to my project:

RPi-PXE-Server

the PXE server itself is working well, because i can PXE boot debian like distributions from that server pretty well.

here, the file structure relative to TFTP root on the PXE server:

/nfs/fedora-x64/<content of fedora LiveDVD>

here, the file structure relative to the PXE boot menu:

/nfs/fedora-x64/<content of fedora LiveDVD>

here, the file structure relative to nfs:

/srv/nfs/fedora-x64/<content of fedora LiveDVD>

and here the PXE menu entry (KERNEL & APPEND boot options) i tried for Fedora:

...
########################################
## INFO: http://people.redhat.com/harald/dracut.html#dracut.kernel
## NOT WORKING
LABEL Fedora x64
    KERNEL /nfs/fedora-x64/images/pxeboot/vmlinuz
    APPEND initrd=/nfs/fedora-x64/images/pxeboot/initrd.img root=nfs:192.168.1.101:/srv/nfs/fedora-x64 root-path=/LiveOS/squashfs.img rootfstype=auto ro rd.live.image rd.lvm=0 rd.luks=0 rd.md=0 rd.dm=0
    TEXT HELP
        Boot to Fedora Workstation Live
        User: liveuser
    ENDTEXT

########################################
## INFO: http://people.redhat.com/harald/dracut.html#dracut.kernel
##       https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/installation_guide/chap-installation-server-setup
## NOT WORKING
LABEL CentOS x64
    KERNEL /nfs/centos-x64/isolinux/vmlinuz0
    APPEND initrd=/nfs/centos-x64/isolinux/initrd0.img root=nfs:192.168.1.101:/srv/nfs/centos-x64 rootfstype=auto ro rd.live.image rd.lvm=0 rd.luks=0 rd.md=0 rd.dm=0
    TEXT HELP
        Boot to CentOS Live GNOME
        User: ...
    ENDTEXT
...

here the PXE boot options i use successfully for debian Live DVD:

...
########################################
LABEL Debian x64
    KERNEL 192.168.1.101/debian-x64/live/vmlinuz-4.9.0-3-amd64
    APPEND initrd=192.168.1.101/debian-x64/live/initrd.img-4.9.0-3-amd64 netboot=nfs nfsroot=192.168.1.101:/srv/nfs/debian-x64 ro boot=live config ...
(more)
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2017-12-24 16:59:27 -0500

Aleksandar Kostadinov gravatar image

updated 2018-01-03 14:31:57 -0500

I had the same issue but it happened only on my first try. Motherboard had a boot option "Legacy LAN" and it worked. I suspect it might be something related to LAN card support in kernel . For you it might be lack of kernel support for your LAN card without for example closed firmware images. Or maybe flaky network. Perhaps you can try when you fall in the error shell to bring up the network card and/or load its driver. Hopefully that will show why process is timing out.

Update (since the above didn't work for you): I see reported fedora 24 booting live-cd like:

default menu
menu title PXE
prompt 0
timeout 200
ontimeout local

label local
  menu label ^Boot from local drive
  menu default
  localboot 0

label fedora-live
  menu label Fedora Workstation LiveBoot
  kernel boot/fedora-live/vmlinuz
  append initrd=boot/fedora-live/initrd.img root=live:http://nas.home.lan/xxx/squashfs.img ro rd.live.image rd.luks=0 rd.md=0 rd.dm=0

I think parameter names mismatch between debian based distros and Red Hat based. I'm not yet sure how booting into a NFS root should work but I know some people have it working as well it shouldn't involve the live-cd squashfs image. You can maybe try running the live-cd first and once it is working you could write a separate question about it (this one is about live media I see).

edit flag offensive delete link more

Comments

i think the network is ok, because the PC is requesting successfully an IP address from the server after initrd0.img is tranferred. so the networkinterface is working.

playing around with the boot parameter, i see that there are also complains about "/dev/mapper/live-rw" does not exist. maybe dracut is expecting a physical dvd drive and is not handling nfs root file system as a live OS.

beta-tester gravatar imagebeta-tester ( 2018-01-03 04:31:00 -0500 )edit

@beta-tester, updated answer

Aleksandar Kostadinov gravatar imageAleksandar Kostadinov ( 2018-01-03 14:32:55 -0500 )edit
1

"Update (since the above didn't work for you): I see reported fedora 24 booting live-cd like:" stupid me. i tried those parameters with CentOS instead of Fedora... with CentOS those parameters are NOT working. but with Fedora 27 it works perfect. (i have to provide an extra http server for that, to provide the squashfs.img via http - but it works)

THANK YOU VERY MUCH.

beta-tester gravatar imagebeta-tester ( 2018-01-17 16:44:54 -0500 )edit

@beta-tester, glad it worked for you. I have a LEDE/Openwrt router at home with USB flash memory. It has uhttpd running for the LuCi configuration interface. I use that server to provide files over HTTP. btw TFTP is very slow compared to HTTP in my network.

Aleksandar Kostadinov gravatar imageAleksandar Kostadinov ( 2018-01-18 02:11:16 -0500 )edit

i use lighttpd as HTTP server and dnsmasq for TFTP server funcrionality. PXE booting Fedora 27, the file transfer rate of the squashfs.img via HTTP is 11Mb/s (~3minutes to transfer) and via TFTP it is 0.5Mb/s (>50minutes to transfer). yes TFTP is way slower than HTTP.

beta-tester gravatar imagebeta-tester ( 2018-01-18 11:49:42 -0500 )edit
0

answered 2017-11-15 13:00:19 -0500

beta-tester gravatar image

bump...

i there really nobody who can help me?!

edit flag offensive delete link more
0

answered 2017-11-23 13:44:12 -0500

beta-tester gravatar image

I am disappointed that no one can offer me a solution here

edit flag offensive delete link more

Comments

I'm sorry about that, but I think there might be someone with a valid solution that posted an answer. Thanks for your question :)

abadrinath gravatar imageabadrinath ( 2017-12-26 06:15:51 -0500 )edit

Question Tools

Stats

Asked: 2017-11-08 01:12:00 -0500

Seen: 2,493 times

Last updated: Jan 17 '18