Ask Your Question
0

Mozilla Firefox/Thunderbird ignoring Gnome's keyboard layout

asked 2017-10-26 10:33:43 -0500

theonlyandy gravatar image

Dear folks.

I hope somebody can help my track down the actualy problem…

Since yesterday, my Firefox and my Thunderbird suddenly both use the American keyboard layout, even though this is not even installed in Gnome.

I only have two German layouts installed, and I'm using Gnome on Wayland.

I tried Firefox in Safe Mode and started it from Terminal, it neither changed anything nor did I get errors about keyboard layouts or the like.

Thanks a bunch.

edit retag flag offensive close merge delete

Comments

Actually Chrome has the problem too. But gedit, terminal, Gnome Shell, Libre Office resprect the Gnome layout.

theonlyandy gravatar imagetheonlyandy ( 2017-10-26 15:03:53 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-11-02 10:27:15 -0500

phrank gravatar image

Hi, I have the same problem on Debian with Gnome on Wayland and found a hint in the Arch Wiki. The X11 keyboard settings differ from the locale settings. On my system:

$ localectl
   System Locale: LANG=de_DE.UTF-8
       VC Keymap: n/a
      X11 Layout: de
       X11 Model: pc105
     X11 Variant: nodeadkeys

$ setxkbmap -query
rules:      evdev
model:      pc105
layout:     us
options:    ctrl:nocaps

Setting this to german manually fixes the symptom:

$ setxkbmap -layout de
edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-10-26 10:33:43 -0500

Seen: 499 times

Last updated: Oct 26 '17