Ask Your Question

Fedora can't detect nvidia / intel GPU on my Dell XPS 15

asked 2017-10-17 12:51:16 -0500

updated 2017-10-18 13:27:01 -0500

I purchased a Dell XPS 15. Fedora works fine. However, it can't detect my GPUs.

$ glxinfo | grep "OpenGL"
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 4.0, 256 bits)
OpenGL version string: 2.1 Mesa 17.2.2
OpenGL shading language version string: 1.30
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 17.2.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions:
$ lspci|grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
$ xrandr --listproviders
Providers: number : 0

It's the same under both Fedora 26 & 27 beta

Edit Oct18: I already tried installing nvidia closed source driver in both rpmfusion and negativo17. it didn't work: GDM failed to launch, so I had to uninstall it.
$ cat /proc/cmdline BOOT_IMAGE=/vmlinuz-4.13.6-300.fc27.x86_64 root=/dev/mapper/fedora_zhenbo-root ro nomodeset rhgb quiett
I want to try PRIME but xrandr --listproviders got nothing. Am I lacking some packages?

edit retag flag offensive close merge delete


You may want to install a second DE, such as Xfce or Enlightenment, and see if you have the same issues. If you do, it's the drivers and if not, it's Gnome. (You can always remove the other DE later, if you don't like it.)

sideburns gravatar imagesideburns ( 2017-10-18 15:02:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-10-17 14:51:58 -0500

ozeszty gravatar image

updated 2017-10-18 15:02:27 -0500

If llvmpipe is used for rendering, then probably you're booting with nomodeset kernel parameter (appended e.g. when you install system in basic graphics mode), check it by running cat /proc/cmdline.

Since you have GTX 1050, nouveau won't work reliably for now (Nvidia's blocking its development) and you'll have to either disable nvidia GPU in BIOS or install Nvidia proprietary driver and Bumblebee (read this wiki: ).

PRIME works only with open-source GPU drivers, it's great on my Intel/AMD laptop (and AMD/AMD or older Intel/Nvidia laptops), but it won't currently work on yours because of bad nouveau support.

Read the wiki I linked and install driver from it (it's intended for optimus laptops like yours). Remove nomodeset and excessive t in quiett, or better yet start fresh installation with updated iso (as it seems you won't have much to backup from current system).

edit flag offensive delete link more


Does the update iso have Bumblebee and other related stuff already installed?

bassib gravatar imagebassib ( 2018-03-29 02:14:26 -0500 )edit

Live respins have same packages as official ISOs, but they are updated. So Bumblebee is not bundled with them (as per wiki post, it's installed from external repository).

ozeszty gravatar imageozeszty ( 2018-03-29 04:34:36 -0500 )edit

Question Tools

1 follower


Asked: 2017-10-17 12:51:16 -0500

Seen: 1,686 times

Last updated: Oct 18 '17