Ask Your Question
2

Why 32-bit version of xorg-x11-drv-nvidia-libs i sneweded in 64-bit system?

asked 2017-09-30 01:48:52 -0500

ptl gravatar image
# dnf clean all && dnf update --refresh -y
46 files removed
Fedora 26 - x86_64 - Updates                     43 MB/s |  15 MB     00:00
Fedora 26 - x86_64                               45 MB/s |  53 MB     00:01
RPM Fusion for Fedora 26 - Free - Updates       234 kB/s | 250 kB     00:01
RPM Fusion for Fedora 26 - Free                 248 kB/s | 519 kB     00:02
RPM Fusion for Fedora 26 - Nonfree - Updates     68 kB/s |  17 kB     00:00
RPM Fusion for Fedora 26 - Nonfree              1.4 MB/s | 158 kB     00:00
Last metadata expiration check: 0:00:00 ago on Sat 30 Sep 2017 09:28:45 AM EEST.
Dependencies resolved.
Nothing to do.
Complete!

# dnf check
xorg-x11-drv-nvidia-libs-2:375.66-7.fc26.x86_64 has missing requires of (xorg-x11-drv-nvidia-libs(**x86-32**) = 2:375.66-7.fc26 if libGL(**x86-32**))
Error: Check discovered 1 problem(s)

# rpm -qa | grep -v -e "\.x86_64$" -e "\.noarch$" -e "^gpg-pubkey-"
# no output, i.e. no 32-bit packets installed

# rpm -qa | grep -i -e nvidia -e libGL | sort
akmod-nvidia-375.66-3.fc26.x86_64
kmod-nvidia-4.12.14-300.fc26.x86_64-375.66-3.fc26.x86_64
libglade2-2.6.4-15.fc26.x86_64
libGLEW-2.0.0-2.fc26.x86_64
libgltf-0.1.0-4.fc26.x86_64
libglvnd-0.2.999-24.20170818git8d4d03f.fc26.x86_64
libglvnd-egl-0.2.999-24.20170818git8d4d03f.fc26.x86_64
libglvnd-gles-0.2.999-24.20170818git8d4d03f.fc26.x86_64
libglvnd-glx-0.2.999-24.20170818git8d4d03f.fc26.x86_64
libglvnd-opengl-0.2.999-24.20170818git8d4d03f.fc26.x86_64
mesa-libGL-17.1.7-1.fc26.x86_64
mesa-libglapi-17.1.7-1.fc26.x86_64
mesa-libGLES-17.1.7-1.fc26.x86_64
mesa-libGLU-9.0.0-11.fc26.x86_64
pygtk2-libglade-2.24.0-16.fc26.x86_64
xorg-x11-drv-nvidia-375.66-7.fc26.x86_64
xorg-x11-drv-nvidia-kmodsrc-375.66-7.fc26.x86_64
xorg-x11-drv-nvidia-libs-375.66-7.fc26.x86_64

What am I doing wrong?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-10-04 15:09:58 -0500

SteveEbey73701 gravatar image

Go proprietary, get away from rpm. I run pure 64bit, did not even install the 32bit compatibility of the proprietary driver. I run wine64 to play world of warcraft, and have no 32 bit programs running, so have had no issues. the proprietary does NOT use xorg-11-nvidia anything, so I can not say for sure but I believe the problem is in one of the rpm drivers.

edit flag offensive delete link more
0

answered 2017-09-30 19:05:28 -0500

SteveEbey73701 gravatar image

Did you install something that is 32 bit, like steam. and it needs the i386 libs? if so, simply install the .i386 of the missing libraries. sudo dnf install xorg-x11-drv-nvidia*.i386

edit flag offensive delete link more

Comments

Not a single 32-bit package installed (or needed).

ptl gravatar imageptl ( 2017-10-01 02:27:09 -0500 )edit

do you still get an error with dnf check? if so, what harm would it do, to install the 32 bit library? are you running low on hard drive space? if you installed rpm, the package maintainer may have included 32 bit library. I use proprietary and dkms so I have control over what I install.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-10-01 13:32:44 -0500 )edit

Hi, I still get the error.

# dnf check
xorg-x11-drv-nvidia-libs-2:375.66-7.fc26.x86_64 has missing requires of (xorg-x11-drv-nvidia-libs(x86-32) = 2:375.66-7.fc26 if libGL(x86-32))
Error: Check discovered 1 problem(s)

I don't want to install any 32-bit packages just because going aroung a bug or something.

Lots of hard disk space, most used filesystem is only 44% full. No HW problems whatsoever.

No manually installer packages, everything has been installed with dnf from standard repos + rpmfusion.

Re-installing all packages that have files in rpm -Va output did not help.

ptl gravatar imageptl ( 2017-10-04 04:58:15 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-09-30 01:48:52 -0500

Seen: 526 times

Last updated: Sep 30 '17