Ask Your Question
0

Help please -- Server stuck "start job running for hold" on boot

asked 2017-09-22 13:27:23 -0500

Tommy-Baltimore gravatar image

Hi there -- I'm begging anyone with the expertise to please help. I have a server that I've spent forever getting everything configured and run a web server on it. I had been mokeying around on it trying to get an ARK game server to run (which I failed at miserably). I don't know if that's related. I did create but then remove a systemd/system service.

Long story -- I rebooted the machine and now I can't get it fully up and running. It hangs on:

[ ok ] Started samba NMB Daemon...
Starting Samba SMB Daemon.
[ ok ] started samba SMB Daemon..
Starting CUPS Scheduler ...
[ ok ] started CUPS Scheduler.
[**   ] A start job is running for Hold until boot process finishes up (54s / no limit) _

Then I sit there for days if I let it. There is no information on what process it is trying to run - I don't know how to recover from this. I tryed putting a USB live CD together and rescue it. Its confusing because if I mount the drives and journalctl -b then I get the live CD journal not the journal I want.

If anyone has clues to help me I owe you big time. Thanks!

Tom

edit retag flag offensive close merge delete

Comments

1

Maybe you can use rescue or emergency mode to fix it?

Or chroot from Live USB to run journalctl on your installed system.

ozeszty gravatar imageozeszty ( 2017-09-22 14:16:02 -0500 )edit

hi! I saw this line a lot three days ago when troubleshooting my problem:

[**   ] A start job is running for Hold until boot process finishes up (54s / no limit) _

If uname -r prints this 4.20.13-200.fc29.x86_64 I assume you had upgraded your system as well -- you could try this: Disabling Graphical Boot Permanently

sender gravatar imagesender ( 2019-03-04 02:59:17 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-09-22 23:31:08 -0500

Nicholas gravatar image

updated 2017-09-22 23:38:06 -0500

Before trying Rescue Mode, try booting in to multi-user mode.

Example (UEFI systems) the grub2.cfg menu entry:

menuentry 'Fedora (4.12.13-300.fc26.x86_64) 26 (Workstation Edition)' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-4.12.13-300.fc26.x86_64-advanced-cb4f51fa-f414-40c9-b208-15f9d89641ce' {
    load_video
    set gfxpayload=keep
    insmod gzio
    insmod part_gpt
    insmod ext2
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root  cb4f51fa-f414-40c9-b208-15f9d89641ce
    else
      search --no-floppy --fs-uuid --set=root cb4f51fa-f414-40c9-b208-15f9d89641ce
    fi
    linuxefi /vmlinuz-4.12.13-300.fc26.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.luks.uuid=luks-cb4f51fa-f414-40c9-b208-15f9d89641ce rd.lvm.lv=fedora/swap rhgb quiet 3
    initrdefi /initramfs-4.12.13-300.fc26.x86_64.img
}

Booting to multi-user target mode

To enter multi-user mode during boot, on the GRUB 2 boot screen, press the e key for edit.

systemd.unit=multi-user.target or 3

linuxefi /vmlinuz-4.11.8-300.fc26.x86_64 root=/dev/mapper/f26-root ro rd.lvm.lv=fedora/root ... rhgb quiet systemd.unit=multi-user.target

- or -

linuxefi /vmlinuz-4.11.8-300.fc26.x86_64 root=/dev/mapper/f26-root ro rd.lvm.lv=fedora/root ... rhgb quiet 3

Booting to Rescue target mode

Rescue mode provides a convenient single-user environment and allows you to repair your system in situations when it is unable to complete a normal booting process. In rescue mode, the system attempts to mount all local file systems and start some important system services, but it does not activate network interfaces or allow more users to be logged into the system at the same time. In Fedora, rescue mode is equivalent to single user mode and requires the root password.

To enter rescue mode during boot, on the GRUB 2 boot screen, press the e key for edit.

Add the following parameter at the end of the linux line on 64-Bit IBM Power Series, the linux16 line on x86-64 BIOS-based systems, or the linuxefi line on UEFI systems:

systemd.unit=rescue.target or 1 or emergency

linuxefi /vmlinuz-4.11.8-300.fc26.x86_64 root=/dev/mapper/f26-root ro rd.lvm.lv=fedora/root ... rhgb quiet systemd.unit=rescue.target

- or -

linuxefi /vmlinuz-4.11.8-300.fc26.x86_64 root=/dev/mapper/f26-root ro rd.lvm.lv=fedora/root ... rhgb quiet 1

- or -

linuxefi /vmlinuz-4.11.8-300.fc26.x86_64 root=/dev/mapper/f26-root ro rd.lvm.lv=fedora/root ... rhgb quiet emergency

Additional Troubleshooting:

systemd-analyze blame
systemd-analyze critical-chain
systemd-analyze critical-chain network.target local-fs.target

sudo systemctl list-dependencies

Now, if you want to disable a service, then you simply do:

systemctl disable <name>

Links:

Fedora 26 Docs

RedHat Managing Systemd Targets

systemd-analyze

edit flag offensive delete link more
0

answered 2017-09-23 23:41:54 -0500

Tommy-Baltimore gravatar image

Hey thanks -- You got me into the machine at least -- I am able to access runlevel 1 but not 3. 3 rejects even root as "permission denied". Bottom line at least I have my files --- I'm just going to nuke it an start over. Thanks for the help!

Best Tom

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-09-22 13:27:23 -0500

Seen: 8,068 times

Last updated: Sep 22 '17