Ask Your Question
1

Touchpad slow after upgrade to fedora 26

asked 2017-09-22 08:06:17 -0500

JanUlrich gravatar image

I did the fedora-upgrade on my ThinkPad T440s

Afterwards the touchpad behaved really slow and kind of delayed. I don't know which parameters I need to change and why the update affected the speed of my touchpad.

Can you help me get my touchpad to the behavior it had on fedora 25?

Here is the output of xinput list-props "SynPS/2 Synaptics TouchPad", maybe it comes in handy:

Device 'SynPS/2 Synaptics TouchPad':
Device Enabled (142):   1
Coordinate Transformation Matrix (144): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Tapping Enabled (280): 0
libinput Tapping Enabled Default (281): 0
libinput Tapping Drag Enabled (282):    1
libinput Tapping Drag Enabled Default (283):    1
libinput Tapping Drag Lock Enabled (284):   0
libinput Tapping Drag Lock Enabled Default (285):   0
libinput Tapping Button Mapping Enabled (286):  1, 0
libinput Tapping Button Mapping Default (287):  1, 0
libinput Natural Scrolling Enabled (288):   0
libinput Natural Scrolling Enabled Default (289):   0
libinput Left Handed Enabled (290): 0
libinput Left Handed Enabled Default (291): 0
libinput Accel Speed (292): 0.000000
libinput Accel Speed Default (293): 0.000000
libinput Scroll Methods Available (294):    1, 1, 0
libinput Scroll Method Enabled (295):   1, 0, 0
libinput Scroll Method Enabled Default (296):   1, 0, 0
libinput Click Methods Available (297): 1, 1
libinput Click Method Enabled (298):    1, 0
libinput Click Method Enabled Default (299):    1, 0
libinput Middle Emulation Enabled (300):    0
libinput Middle Emulation Enabled Default (301):    0
libinput Send Events Modes Available (265): 1, 1
libinput Send Events Mode Enabled (266):    0, 0
libinput Send Events Mode Enabled Default (267):    0, 0
libinput Disable While Typing Enabled (302):    1
libinput Disable While Typing Enabled Default (303):    1
Device Node (268):  "/dev/input/event16"
Device Product ID (269):    2, 7
libinput Drag Lock Buttons (304):   <no items>
libinput Horizontal Scroll Enabled (305):   1
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-10-01 03:44:52 -0500

hedayat gravatar image

If it is too slow, try updating your Fedora if you've not done so already. Then, if problem still persists, I think you should look for an existing bug in http://bugzilla.redhat.com/ , or fill a new bug ( https://bugzilla.redhat.com/enter_bug... ).

edit flag offensive delete link more

Comments

It got worse, no the two finger scroll isn't working anymore either. I use libinput version 1.8.2 and xinput version 1.6.2 (XI Versione on server: 2.3)

the output of xinput list-props "SynPS/2 Synaptics TouchPad":

Device 'SynPS/2 Synaptics TouchPad':`
Device Enabled (141):   1
Coordinate Transformation Matrix (143): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Tapping Enabled (279): 0
libinput Tapping Enabled Default (280): 0
libinput Tapping Drag Enabled (281):    1
libinput Tapping Drag Enabled Default (282):    1
JanUlrich gravatar imageJanUlrich ( 2017-10-06 09:17:45 -0500 )edit

Just to be sure: make sure that two finger scrolling is enabled in touchpad settings. Anyway, you should probably report/find the bug.

hedayat gravatar imagehedayat ( 2017-10-06 15:54:53 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-09-22 08:06:17 -0500

Seen: 294 times

Last updated: Oct 01 '17