Ask Your Question

Desktop Launcher Will Not Launch Monero Wallet - Gome/'26

asked 2017-09-10 01:22:09 -0500

x27qb8 gravatar image

updated 2017-09-10 01:38:47 -0500

The desktop-launcher I created to launch the Monero Wallet application won't lauch the application.

The Monero Wallet application is run in its own folder from a shell-script and doesn't need to run in a terminal. I start these from desktop-launchers all-the-time; never been a problem. This one is a bit of a mystery. The shell-script I'm trying to launch is as follows:

export LD_LIBRARY_PATH=`pwd`/libs
export QT_PLUGIN_PATH=`pwd`/plugins
export QML2_IMPORT_PATH=`pwd`/qml

This shell-script launches a binary. I could run this directly; but the LD statements need to be executed first to prepare the execution environment. Do I need to add the executable to $PATH, or is there a more elegant way of doing this?

Here's my desktop-launcher code:

[Desktop Entry]
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-09-10 07:43:44 -0500

The desktop-launcher is run in /home/user normally and not in the path the executable is called. I assume that it should be /home/user/monero-gui- in which the shell script should be run.

I would suggest to use absolute pathes in your script as follwos.


export APP_PATH="/home/user/monero-gui-" 
export LD_LIBRARY_PATH="${APP_PATH}"/libs 
export QT_PLUGIN_PATH="${APP_PATH}"/plugins 
export QML2_IMPORT_PATH="${APP_PATH}"/qml 


The last line depends on where your executable is. Normally this is in the bin directory, so it also could be.

edit flag offensive delete link more


SUH-WEET, works like a charm.


x27qb8 gravatar imagex27qb8 ( 2017-09-10 11:35:25 -0500 )edit

Question Tools

1 follower


Asked: 2017-09-10 01:22:09 -0500

Seen: 209 times

Last updated: Sep 10 '17