[CENTOS7]yum error ipa-client-4.4.0-14.el7.centos.7.x86_64

asked 2017-09-02 18:04:23 -0500

perromercenario gravatar image

updated 2017-09-03 05:51:21 -0500

hhlp gravatar image

good afternoons today i have to forcefully restart mi server for a trouble whit mate-panel eating all mi ram

at restart i decide to update the server and get this
[code]

[root@pc0050 admm00]# yum update

Complementos cargados:fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
 * base: centos.uniminuto.edu
 * epel: mirror.cedia.org.ec
 * extras: centos.uniminuto.edu
 * updates: centos.uniminuto.edu
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Paquete lightdm.x86_64 0:1.10.6-4.el7 debe ser actualizado
---> Paquete lightdm.x86_64 0:1.18.3-3.el7 debe ser una actualización
---> Paquete lightdm-gobject.x86_64 0:1.10.6-4.el7 debe ser actualizado
---> Paquete lightdm-gobject.x86_64 0:1.18.3-3.el7 debe ser una actualización
--> Procesando dependencias: glib2(x86-64) >= 2.50.3 para el paquete: lightdm-gobject-1.18.3-3.el7.x86_64
--> Resolución de dependencias finalizada
Error: Paquete: lightdm-gobject-1.18.3-3.el7.x86_64 (epel)
           Necesita: glib2(x86-64) >= 2.50.3
           Instalado: glib2-2.46.2-4.el7.x86_64 (@anaconda)
               glib2(x86-64) = 2.46.2-4.el7
 Podría intentar utilizar el comando --skip-broken para sortear el problema
** Se ha encontrado 3 problema(s) pre existentes en la base de datos RPM, este es el resultado de 'yum check':
ipa-client-4.4.0-14.el7.centos.7.x86_64 se ha instalado choca con freeipa-client: ipa-client-4.4.0-14.el7.centos.7.x86_64
ipa-client-common-4.4.0-14.el7.centos.7.noarch se ha instalado choca con freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.7.noarch
ipa-common-4.4.0-14.el7.centos.7.noarch se ha instalado choca con freeipa-common: ipa-common-4.4.0-14.el7.centos.7.noarch

[root@pc0050 admm00]# yum install NetworkManager-l2tp

Complementos cargados:fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
 * base: centos.uniminuto.edu
 * epel: mirror.cedia.org.ec
 * extras: centos.uniminuto.edu
 * updates: centos.uniminuto.edu
El paquete NetworkManager-l2tp-1.2.8-1.el7.x86_64 ya se encuentra instalado con su versión más reciente
Nada para hacer
#

how is this package get into mi updates asking for a version of glibc2 I don't have access to

Error: Package: lightdm-gobject-1.18.3-3.el7.x86_64 (epel)
           Needs: glib2(x86-64) >= 2.50.3
           Instaled: glib2-2.46.2-4.el7.x86_64 (@anaconda)

#

next the cherry from the cake

ipa-client-4.4.0-14.el7.centos.7.x86_64 has been installed conflicts whit freeipa-client: 
ipa-client-4.4.0-14.el7.centos.7.x86_64

this package is in conflict whit itself ??

the same goes whit this other two:

ipa-client-common-4.4.0-14.el7.centos.7.noarch se ha instalado choca con freeipa-client-common: 
ipa-client-common-4.4.0-14.el7.centos.7.noarch

ipa-common-4.4.0-14.el7.centos.7.noarch se ha instalado choca con freeipa-common: 
ipa-common-4.4.0-14.el7.centos.7.noarch

[/code]

#

this are mi repos: 
[code]
[root@pc0050 admm00]# yum repolist
Complementos cargados:fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
 * base: centos.uniminuto.edu
 * epel: mirror.cedia.org.ec
 * extras: centos.uniminuto.edu
 * updates: centos.uniminuto.edu
id del repositorio     nombre del repositorio                             estado
MEGAsync               MEGAsync                                               11
base/7/x86_64          CentOS-7 - Base                                     9.363
epel/x86_64            Extra Packages for Enterprise Linux 7 - x86_64     11.858
extras/7/x86_64        CentOS-7 - Extras                                     451 ...
(more)
edit retag flag offensive close merge delete