Ask Your Question

HDMI 1440p Monitor not displaying correctly. Fedora 26

asked 2017-08-23 21:29:44 -0500

jorepstein1 gravatar image

updated 2017-08-26 02:19:08 -0500

Hi all, I just brought home a 1440p monitor to use. It works fine on my windows partition but is having some issues on Fedora 26.

I am using a RX 580 with an Asus PB258 and it is not looking good. I really don't know what to do to fix this, help would be appreciated.

Here are some pictures of what's happening.

EDIT: I tried installing Ubuntu to see if it worked. I was excited when the monitors were working correctly from the sample OS that runs off of the USB drive and lets you install the OS. I happily installed Ubuntu because it seemed to be working. However, when I finally ran Ubuntu from disk, the monitor was having the same issue as on Fedora. Why would this be? Could it be some software update thats downloaded during installation??

Surprisingly, the resolution is correctly set as shown below in my monitors.xml file

VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/580] [1002:67df] (rev e7)
    Subsystem: Tul Corporation / PowerColor Device [148c:2378]
    Kernel driver in use: amdgpu
    Kernel modules: amdgpu

<output name="HDMI-1">
  <product>ASUS PB258</product>
edit retag flag offensive close merge delete


AMDGPU-PRO is incompatible with Fedora 26, you should remove it and use built-in amdgpu driver (it's possible that you're using it already, but some parts of PRO driver are interfering).

ozeszty gravatar imageozeszty ( 2017-08-25 15:41:43 -0500 )edit

I removed the amdgpu-pro drivers and made sure I am using the amdgpu drivers. It still doesnt work. Does anyone know what this screen effect would even be called so I can research it more?

jorepstein1 gravatar imagejorepstein1 ( 2017-08-25 23:50:41 -0500 )edit

Compare lsmod, xrandr and mentioned by alextheoto cat /sys/class/drm/card0/device/power_dpm_force_performance_level output between live and installed linux.

You might also try out this kernel with upcoming, completely rewritten display code

ozeszty gravatar imageozeszty ( 2017-08-26 03:33:26 -0500 )edit

@ozeszty Here is the results from both of those commands on live and installed ubuntu. powerdpmforceperformance_level was auto for both.

jorepstein1 gravatar imagejorepstein1 ( 2017-08-26 15:05:43 -0500 )edit

@ozeszty your reccomendatoin to try xrandr led me in the right direction to load Classic GNOME which fixed the problem. I wonder if theres a better solution!

jorepstein1 gravatar imagejorepstein1 ( 2017-08-26 15:31:28 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2017-08-26 15:30:23 -0500

jorepstein1 gravatar image

updated 2017-08-27 20:24:23 -0500

I came up with a solution, though I'd love some expanded input on whether this is an acceptable long term solution.

I followed the screenshot here:enter image description here

Which I found from the debugging Wayland page Using both GNOME Classic and GNOME on Xorg allowed me to correctly run the HDMI monitor at 1440p. Note that this switches your primary display from Wayland to X11. It'd be nice to be able to correctly use wayland on this monitor. Also I tried this on Ubuntu, but surely it would work on Fedora as well. Thanks for the help!

EDIT: It seems that the problem comes back occasionally. All I have to do to resolve the problem is to log in under GNOME Classic then log out and back in under regular GNOME

edit flag offensive delete link more

answered 2017-08-26 02:28:37 -0500

alextheoto gravatar image

Take a look here.

edit flag offensive delete link more

Question Tools


Asked: 2017-08-23 21:29:44 -0500

Seen: 795 times

Last updated: Aug 27 '17