Ask Your Question
0

realtek ethernet connectivity issues

asked 2012-11-11 00:48:26 -0500

xwhiteknuckle22 gravatar image

updated 2013-08-20 05:47:18 -0500

FranciscoD_ gravatar image

I am having a connectivity issue with a wired connection. When the line is plugged into the wireless router it works fine. Then I plug the line directly into my computer and...nothing! Can't configure a wired network in the network settings...nothing.

I've tried configuring a wired network - set 'Connect automatically', 'Available to all users' and the 'Device MAC address' (which I got from ifconfig) . I tried downloading the latest drivers from Realtek's website and installing with: make clean modules && make install then re-booting and still the same problem.

The output from lspci -v (edited for length/clarity):

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
    Subsystem: ASUSTeK Computer Inc. P8P67 Deluxe Motherboard [Realtek RTL8111E]
    Flags: bus master, fast devsel, latency 0, IRQ 43
    I/O ports at e800 [size=256]
    Memory at fdfff000 (64-bit, prefetchable) [size=4K]
    Memory at fdff8000 (64-bit, prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Endpoint, MSI 01
    Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
    Capabilities: [d0] Vital Product Data
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [140] Virtual Channel
    Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
    Kernel driver in use: r8168

03:00.0 Network controller: Ralink corp. RT2860
    Subsystem: ASUSTeK Computer Inc. Device 130f
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at febf0000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable- Count=1/32 Maskable- 64bit+
    Capabilities: [70] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Kernel driver in use: rt2800pci

Does anyone know what I should do next?? If you need any more info to help just ask...

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-08-20 04:40:51 -0500

nixfas gravatar image

Execute system-config-network, if is not installed, install it: yum install system-config-network

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-11-11 00:48:26 -0500

Seen: 1,001 times

Last updated: Aug 20 '13