Ask Your Question

How to enable Gnome Shell extensions?

asked 2011-11-20 06:45:37 -0500

KovBal gravatar image

updated 2011-11-21 13:04:15 -0500

On Fedora 16 I installed a couple of extensions like alternate-tab and dock, but the only difference was made by the cpu-temperature.

I tried gnome-tweak-tool, but I couldn't enable the others. I also tried logging off and on again, but nothing happened.

Update: I upgraded the packages and now I can see them in gnome-tweak-tool.

edit retag flag offensive close merge delete


So is this solved? Mark an answer...

lzap gravatar imagelzap ( 2011-12-15 13:53:55 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2011-12-15 04:38:39 -0500

SoumyaC gravatar image

You can easily enable Gnome Shell Extensions from

No need of any tweak software or any manual change in files.

edit flag offensive delete link more

answered 2011-12-15 13:53:10 -0500

lzap gravatar image

The problem can be with incompatibility. Open metadata.json of your extension and edit shell-version variable to include your version of Gnome Shell:

  "shell-version": ["3.0", "3.0.1", "3.0.2", "3.2"], 
  "uuid": "",
  "name": "Disable Window Animations",
  "description": "Disables window manager animations including workspace switching"

Then restart.

edit flag offensive delete link more

Question Tools


Asked: 2011-11-20 06:45:37 -0500

Seen: 20,204 times

Last updated: Dec 15 '11