Ask Your Question
0

Ask for "update" for package in repos

asked 2017-08-09 08:28:17 -0500

malcolmmaya gravatar image

updated 2017-08-09 08:28:40 -0500

Hello all,

I would like to ask if it is possible to compile the package for PCL and VTK with QT5 instead of QT4, and if it's not, why that is not possible but I have no idea where to ask this type of question, where would that be ? So I'm starting from here :).

Thanks a lot,

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-08-09 08:48:18 -0500

Aeyoun gravatar image

updated 2017-08-09 08:49:08 -0500

Is Qt5 supported by upstream (the package developer)? If not then you need to talk to upstream first.

If Qt5 is supported by upstream and Fedora is shipping an old version of the package, you can file a bug in the Fedora bug tracker. Read up on the process first and then file your report.

If it is supported you could try modifying the build scripts and do it yourself. I wrote a quick tutorial for beginners on updating packages from source RPMs. You could give it a try and then lend upstream a helping hand with updating their stuff to Qt5 which would eventually land a newer version downstream in Fedora.

edit flag offensive delete link more

Comments

upstream supports QT5, it's more that it can be compiled with one or the other. So I was also wondering what motivated the choice of QT4

malcolmmaya gravatar imagemalcolmmaya ( 2017-08-09 09:30:43 -0500 )edit

You may want the package maintainer that question: https://apps.fedoraproject.org/packag...

Same for PCL

florian gravatar imageflorian ( 2017-08-09 10:10:55 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-08-09 08:28:17 -0500

Seen: 73 times

Last updated: Aug 09 '17