Ask Your Question
2

Newby needs support setting up Fedora 26

asked 2017-08-04 13:48:52 -0500

Mash gravatar image

Hello,

I am using an Asus G75VX with Windows 10 installed.

I wanted to start to use Fedora but I am totaly new to the world of Linux.

I planned to set everything up for dual use according to this guide. https://geeksocket.in/blog/dualboot-f...

After finishing the installation I am able to choose between the operating systems during start up

the options are Fedora / Fedora rescue and windows.

When i try to start Fedora 26 i reach the login screen but after loging in the screen goes black the only thing I see is the cursor. I am not able to move the cursor and also no error messages are occuring.

I am not sure where i went wrong I would appreciate any advices google searches didn`t bring me anywhere.

best regards

edit retag flag offensive close merge delete

Comments

1

Welcome to ask.fedora. This is a fairly common issue in new installs, generally caused by problems with your graphics adapter. Try this: boot into Fedora, and when you get to the black screen, press Ctrl, Alt and F2 (Function Key 2) all together. This will get you to a command line screen. Log in and run this command: lspci | grep VGA and copy down the output. Use the command reboot and go back to Windows. Then, come here and put that line into a comment, so that we'll know what you're using.

sideburns gravatar imagesideburns ( 2017-08-04 15:53:00 -0500 )edit

Thank you with changing to x.org i was able to login.

What are the differences between these login options?

Mash gravatar imageMash ( 2017-08-05 03:03:37 -0500 )edit

You're welcome. I'll explain the differences in my (edited) answer :)

arya s. gravatar imagearya s. ( 2017-08-05 03:17:15 -0500 )edit

When i am on the command line screen i am requested to login but i am not able to.

On the graphical interface the username is for example "test" (not the real username) so i can click on it and login with my password.

When i want to login on the command line screen i will have to use "test" as username or is it necessary to use any command upfront.

By Using localhost login: Root Password: *

I always receive the notification that i the login is incorrect

Mash gravatar imageMash ( 2017-08-05 03:19:09 -0500 )edit

All right I have updated my answer below.

As for the command line interface (in Linux they commonly called console btw.), you input the same username and password as you would use in GUI login, by the way everything is case sensitive in Linux (unlike Windows) and the default superuser account is 'root' not 'Root'.

arya s. gravatar imagearya s. ( 2017-08-05 04:23:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-08-04 18:42:17 -0500

arya s. gravatar image

updated 2017-08-05 06:20:36 -0500

When on login screen, press the gear icon and pick 'Gnome in X.org', see if would let you login. The difference between default and X.Org session is that in default you are using the newer variant of display server called Wayland) instead of the soon-to-be-legacy X Window System.

(The technical differences between these two display server is out of scope of your question. However this ELI5 from Reddit gives a nice overview, and this article goes into more details.)

The main point is, being newer implementation means Wayland does yet not support everything (and/or other things do not yet support Wayland), in your case most likely it is related to your graphic card: in general, nVidia graphic card does not (fully) support Wayland session, yet due to its driver implementation.

The default open source nVidia driver that comes with Fedora is called Nouveau, Nouveau is said to support Wayland, but there is no definite guarantee that it works properly for all nVidia graphic card especially the newer ones. Yours probably falls into this category. This is most likely the cause you cannot login into Wayland session.

Modern laptop usually is equipped with switchable graphic card combo, (e.g Intel + nVidia or Intel + AMD). In this case running it on Intel graphic will allow most people to use the Wayland session, but I checked that in the case of your laptop model (Asus ROG-G75VX) you can only have nVidia card usable.

You can try to debug and to verify if the problem is indeed caused by the graphic driver, if it is true then you can only use Gnome X.org until Nouveau fully supports your graphic card, or the proprietary official driver (the one you download separately from nVidia website) properly supports Wayland.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-08-04 13:48:52 -0500

Seen: 245 times

Last updated: Aug 05 '17