Ask Your Question
0

fstab does not work a network drive

asked 2012-04-17 13:57:38 -0500

la7low gravatar image

updated 2012-05-01 13:18:29 -0500

i can mount a network drive with mount without problem: mount -t cifs //192.168.1.1/share /media/NAS I can see the files afterwards. I put the following to fstab for automount: //192.168.1.1/share /media/NAS cifs defaults 0 0 but the network share is not mounted after restart.

What should I do? Any suggestions? I could make this work on linux mint previously although dont remember the exact fstab line...it's annoying me I can1t make it work on fedora. Thanks for any help in advance!

UPDATE FOR MY QUESTION: After modifying the /etc/fstab file with the line: "//192.168.1.1/share /media/NAS cifs guest,_netdev 0 0" and running "mount -av", I got the following message:

"mount.cifs kernel mount options: ip=192.168.1.1,unc=\192.168.1.1\share,guest,ver=1,user=,pass=** nothing was mounted"

It seems it can't use the "_netdev" option, doesn't it? Why? What to do? Automount still not working....

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-04-17 14:14:04 -0500

ztank1013 gravatar image

Try using this line in /etc/fstab

//192.168.1.1/share  /media/NAS   cifs    guest,_netdev   0 0

then run

mount -av

and report the output if the problem is still there.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-04-17 13:57:38 -0500

Seen: 4,443 times

Last updated: May 01 '12