Ask Your Question
2

Wrong laptop battery level

asked 2012-05-23 12:56:09 -0500

akiross gravatar image

Hello,

I'm on an eeepc 1005HA, running F16. Problem is: when battery status goes around 20%, the computer shuts down totally, as batteries are actually empty.

How can I fix this? Or at least, auto-suspend the computer when something like 25% is reached?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-05-23 16:12:25 -0500

ztank1013 gravatar image

Running this command you should get the info you are looking for:

gsettings list-recursively |grep -i percentage
org.gnome.settings-daemon.plugins.power percentage-action 2
org.gnome.settings-daemon.plugins.power percentage-critical 3
org.gnome.settings-daemon.plugins.power percentage-low 10

It is basically saying that you will get a first warning for battery low at 10%, a critical warning at 3%, and finally some action when battery is at 2%.

In your case you should check for these values and also for the associated action. Run this to find info about your curent critical-battery-action:

gsettings list-recursively |grep -i critical-battery-action
org.gnome.settings-daemon.plugins.power critical-battery-action 'hibernate'

In may case I have an hibernate action associated.

If you want to change your values you can use the set directive in gsettins command:

gsettings set org.gnome.settings-daemon.plugins.power critical-battery-action hibernate
edit flag offensive delete link more
0

answered 2013-01-10 18:47:21 -0500

I have the same settings in my F16 with ThinkPad L420, but it still does shuts down totally, as batteries are actually empty.

Do I need to install any packages (like acpid,pm-utils)?

Please do let me know how can I resolve this issue?

thanks in advance :)

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-05-23 12:56:09 -0500

Seen: 1,590 times

Last updated: Jan 10 '13