Ask Your Question
1

1 tb fat32 hadrive ask for password to mount

asked 2017-07-21 21:23:23 -0600

wbiggs203 gravatar image

I installed fedora 26 64 bit on my pc I have 2 1tb hard drive installed in it When I install any ver of 26 When I try to access the drive I get it asking me for my password to mount the drive . But after I mount the drive I can access it all the time . it is just when I try to access it when I first boot . But if I try to access it from a live usb drive I can access it with out the password . all so I have tried to make it ext4 same error But when i had windows 10 on it I did not have and errors .

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-07-22 03:06:35 -0600

muep gravatar image

updated 2017-07-22 03:16:44 -0600

The liveuser account in the environment you boot from USB does not have a password, so the usual password prompt gets just skipped in many places where there would normally be a prompt for being able to do some privileged operation.

The password prompt that you get while mounting the disk is just for mounting the disk and not for protecting the contents of the disk. So once you have mounted it, it tends to stay mounted until you tell Fedora to unmount it or if you reboot. Until then, accessing the disk would not normally give you any further password prompts.

Also note that the mount permission is needed regardless of what the filesystem type is. Changing between fat32 and ext4 will not change this requirement, but otherwise I'd think that something else than fat32 would be a good idea for a 1 TB volume.

The default configuration in Fedora would allow local users to manage external disks without extra authentication. However, internal disks are treated a bit more strictly and there an administrator password is required by default.

If you want to make internal disks mountable by local users without password, this default policy can be overridden by adding a configuration file with this content into /etc/polkit-1/rules.d/20-permit-internal-disks.rules.

polkit.addRule(function(action, subject) {
    if (action.id == "org.freedesktop.udisks2.filesystem-mount-system" &&
        subject.local) {
        return polkit.Result.YES;
    }
});

If something similar but not exactly this is needed, running man polkit gives you a description of the configuration format. The action id names for many disk related actions can be found from the /usr/share/polkit-1/actions/org.freedesktop.UDisks2.policy file.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-07-21 21:23:23 -0600

Seen: 96 times

Last updated: Jul 22 '17