Ask Your Question
1

Lenovo x220 high temperature and constant fan equals poor battery life

asked 2012-11-04 13:25:20 -0500

johnpoelstra gravatar image

In the past three weeks I've noticed that Fedora 17 is not performing the way it used to on my Lenovo x220. It averages temperatures of 60C and htop shows the system is inactive. In the past, normal temp was around 40C in the same conditions and the fan would barely be running, if at all.

This shortens what used to be around 9 hours of battery life to about 2 :(

Any suggestion on how to troubleshoot or resolve this problem? Booting into older kernels doesn't appear to produce better results.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2012-11-05 10:05:04 -0500

pfrields gravatar image

updated 2012-11-05 10:05:40 -0500

I just noticed this problem recently myself on my x220, model 4286CTO. However, the recent kernel-3.6.3-1.fc17.x86_64 update package appears to have fixed the problem. My x220 was running over the entire weekend and is operating at a nominally cool temperature this morning. I didn't introduce any BIOS update in between.

edit flag offensive delete link more
1

answered 2012-11-16 16:19:07 -0500

johnpoelstra gravatar image

updated 2012-11-16 16:20:18 -0500

Appears I'm not the only one with this problem. Issue is being tracked in this bug: https://bugzilla.redhat.com/show_bug.cgi?id=866212

Quick summary: from cold boot everything is fine. After suspend/resume power consumption goes through the roof.

My current workaround is to install and boot from the kernel that Fedora 17 GA'd with or not suspend/resume unless I'm willing to pay the price. :)

edit flag offensive delete link more
0

answered 2012-12-05 14:40:57 -0500

stickster gravatar image

Yup, as we discovered this seemed to happen sometime in the 3.6 cycle, and affects the system after a suspend/resume. After a cold boot the problem disappears. Apparently there's a fix coming in kernel 3.8 but that's a ways off. In the meantime, you may be able to work around this problem at least sometimes by adding this to your kernel's boot line in /boot/grub2/grub.cfg (the line that starts with vmlinuz):

i915.i915_enable_rc6=7

I've found this takes care of the problem about 2 out of 3 times when I resume. If the problem comes back, which I verify using powertop and looking at the "Idle Stats," I just suspend and resume again until it disappears. It usually only takes one additional suspend/resume for that to happen.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-11-04 13:25:20 -0500

Seen: 2,868 times

Last updated: Dec 05 '12