Ask Your Question
0

upgrade to f26 fails: package conflict

asked 2017-07-15 00:22:12 -0500

Emmanuel Touzery gravatar image

i get a package conflict message but the package appears to conflict with itself..? what can I do?

Error running transaction: package libmpeg2-0.5.1-12.fc25.x86_64 is already installed
file /usr/lib64/libmpeg2.so.0.1.0 from install of libmpeg2-0.5.1-12.fc25.x86_64 conflicts with file from libmpeg2-0.5.1-12.fc25.x86_64
file /usr/lib64/libmpeg2convert.so.0.0.0 from install of libmpeg2-0.5.1-12.fc25.x86_64 conflicts with file from libmpeg2-0.5.1-12.fc25.x86_64
package twolame-libs-0.3.13-5.fc25.x86_64 is already installed
file /usr/lib64/libtwolame.so.0.0.0 from install of twolame-libs-0.3.13-5.fc25.x86_64 conflicts with file from twolame-libs-0.3.13-5.fc25.x86_64
package libmimic-1.0.4-9.fc25.x86_64 is already installed
file /usr/lib64/libmimic.so.0.0.1 from install of libmimic-1.0.4-9.fc25.x86_64 conflicts with file from libmimic-1.0.4-9.fc25.x86_64
package libmms-0.6.4-4.fc25.x86_64 is already installed
file /usr/share/doc/libmms/ChangeLog from install of libmms-0.6.4-4.fc25.x86_64 conflicts with file from libmms-0.6.4-4.fc25.x86_64
file /usr/lib64/libmms.so.0.0.2 from install of libmms-0.6.4-4.fc25.x86_64 conflicts with file from libmms-0.6.4-4.fc25.x86_64
package mplayer-common-1.3.0-7.fc25.x86_64 is already installed
file /etc/mplayer/mplayer.conf from install of mplayer-common-1.3.0-7.fc25.x86_64 conflicts with file from mplayer-common-1.3.0-7.fc25.x86_64
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-07-15 00:43:06 -0500

Emmanuel Touzery gravatar image

Right so I was using the Software GUI. I had to run it in command-line with the --allowerasing flag as described there: https://fedoramagazine.org/upgrading-...

edit flag offensive delete link more
1

answered 2017-07-15 00:35:25 -0500

aeperezt gravatar image

What you need to do is to remove conflict packages and reinstall them after upgrade, those conflicts are because rpmfusion or other repository that are not update to Fedora 26.

edit flag offensive delete link more

Comments

thanks for the tip! turns out dnf can already do that for me with --allowerasing. I'll rather go with that. Too bad the GUI doesn't support that and doesn't hint about that possible option.

Emmanuel Touzery gravatar imageEmmanuel Touzery ( 2017-07-15 00:51:33 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-07-15 00:19:51 -0500

Seen: 342 times

Last updated: Jul 15 '17