Ask Your Question
1

VLC issue on Fedora 26

asked 2017-07-14 00:01:40 -0500

miccvaki gravatar image

Hi all,

I have just recently upgraded from F25 to F26. Unfortunately since then I cant watch any movies using VLC. I had some issues on F25 too, however I was able to solve them by downgrading VLC.

F26 doesnt let me to downgrade the player, it says its already the lowest version. Only audioworks.

I would appriciate any comments on this. Also I would be glad to hear any suggestions about other media player which works on F26. Dont include Gnome videos pls as its lagging for me.

Thanks.

edit retag flag offensive close merge delete

Comments

just out of curiosity...does all of your colours gets messed up?

luca247 gravatar imageluca247 ( 2017-07-14 01:11:28 -0500 )edit

Hi Luca, Not really, but I used to have this kind of issue. I guess you are talking about pixelated grey screen. If its the case then here is the solution:

"PREFERENCES --> Show Settings --> All Input/Codecs --> [ADVANCED] File Caching Default 300ms ; changed to 10000ms

WORKED FOR ME."

miccvaki gravatar imagemiccvaki ( 2017-07-14 16:05:47 -0500 )edit

no i'm not using vlc...i was asking because i'm having problems with every gstreamer based player...seems that everytime i play i videos my desktop colours gets messed up...

luca247 gravatar imageluca247 ( 2017-07-15 02:27:50 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-07-14 03:57:10 -0500

davidva gravatar image

What is the source of your vlc?

Please share it:

rpm -q vlc

dnf info vlc

If your source is rpmfusion, you can't go back a previous package with the new release because doesn't exist... Then I suggest you install vlc from unitedrpms... Crazy boys; But the vlc works great with wayland session ... Ever the correct way is report the issue in the correct chanels.. Because the maintainers put your attention in your chanels...

edit flag offensive delete link more

Comments

Thanks for this suggestion. I have clean installed it from unitedrpms (meantime disabling rpmfusion just to make sure there will be no issues). I got a higher version vlc player, but gives me error regarding codecs. Here all the details:

rpm -q vlc vlc-3.0.0-39.git89b077e.fc26.x86_64

VLC error:Codec not supported: VLC could not decode the format "a52 " (A52 Audio (aka AC3))

At the moment VLC is freezing when I try to open a video.

miccvaki gravatar imagemiccvaki ( 2017-07-14 16:13:24 -0500 )edit

Very strange, the support was enabled in the build and the codec is working fine... can you explain what format of video and if you are using a convert of videos... Very strange, the support was enabled in the build and the codec is working fine... can you explain what format of video and if you are using a convert of videos... Also can you share your a52dec version?

rpm -q  a52dec

image description

davidva gravatar imagedavidva ( 2017-07-14 23:42:53 -0500 )edit

Other idea, you can remove the local data and configuration!!

rm -rf $HOME/.local/share/vlc

rm -rf $HOME/.config/vlc
davidva gravatar imagedavidva ( 2017-07-14 23:53:24 -0500 )edit

Thank you above suggestion. I have managed to get work this audio decoder by your help but I am seeing an another error now when trying to play a file..

VLC could not decode the format "dts " (DTS Audio)

I also ran the command for local data removal and config. At the meantime I have installed mpv player just for testing and it's able to play the movies so it's really crazy :)

miccvaki gravatar imagemiccvaki ( 2017-07-15 04:05:04 -0500 )edit

dts was enabled in build... check if you have installed libdca

rpm -q libdca

image description

davidva gravatar imagedavidva ( 2017-07-15 10:10:56 -0500 )edit
0

answered 2017-07-14 14:48:59 -0500

ssieb gravatar image

updated 2017-07-14 14:52:11 -0500

In the VLC preferences, in the Video section, I expect that the output setting is currently set to "automatic". Try some of the other options and see if one of them works better.

You could also try mplayer. There are graphical interfaces for it as well.

edit flag offensive delete link more

Comments

Hey, thank you for the idea. Tried all the three options (auto, on, off) and even played with Video - Mode but it didn't solved my case

miccvaki gravatar imagemiccvaki ( 2017-07-14 16:18:37 -0500 )edit

That was not the right setting. You want the one above that which is labelled "Output".

ssieb gravatar imagessieb ( 2017-07-14 21:13:43 -0500 )edit

Thanks for correcting, I have tried but either of the options made any difference.

miccvaki gravatar imagemiccvaki ( 2017-07-15 04:05:51 -0500 )edit

I just realized I was making some assumptions about what your problem is. Can you please provide more specific information in the question about what you are trying to do and what is happening?

ssieb gravatar imagessieb ( 2017-07-17 12:54:21 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-07-14 00:01:40 -0500

Seen: 3,203 times

Last updated: Jul 14 '17