Ask Your Question
1

Fedora 26 Fails To Detect openSUSE TW On Btrfs

asked 2017-07-11 08:41:31 -0500

Madno gravatar image

I have a hard disk with multiple Linux distributions on different partitions. My main distro was openSUSE, but I installed Fedora 26 on another partition and made it controls GRUB.

However, It can detect Windows and Ubuntu in the booting menu, but not openSUSE Tumbleweed.

I have tried to run:

[root@localhost ~]# grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.11.8-300.fc26.x86_64
Found initrd image: /boot/initramfs-4.11.8-300.fc26.x86_64.img
Found linux image: /boot/vmlinuz-0-rescue-86d2fc1085f94992aa834b8ccad30da2
Found initrd image: /boot/initramfs-0-rescue-86d2fc1085f94992aa834b8ccad30da2.img
mount: mount(2) failed: /var/lib/os-prober/mount: No such file or directory
Found Windows 10 on /dev/sda1
Found openSUSE Tumbleweed on /dev/sda3
Found Ubuntu 17.04 (17.04) on /dev/sda4
done

As you can see, it detects it exists, however, it's not the boot menu. (there doesn't even exist an entry for it in /boot/grub2/grub.cfg).

My openSUSE installation is using a Btrfs filesystem. Different subvolumes are there. I can access the partition easily from the file manager. But I just can't boot into it.

edit retag flag offensive close merge delete

Comments

Let openSUSE control GRUB.

florian gravatar imageflorian ( 2017-07-11 10:43:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-07-11 09:42:47 -0500

cmurf gravatar image

SUSE GRUB is heavily patched to support the unique layout used for Btrfs by default. Those patches aren't upstream and aren't in Fedora. You're best off doing it the other way around, with SUSE GRUB booting Fedora. It might be possible to add to Fedora 40custom or 41custom, a menu entry that uses configfile command to point to the SUSE grub.cfg. But I'm not certain the SUSE grub.cfg will be interpreted correctly by Fedora GRUB. The format is the same, but the handling of Btrfs subvolumes is totally different between the code bases. Of course you need to run grub2-mkconfig on Fedora once you edit anything in /etc/grub.d/

edit flag offensive delete link more

Comments

Thank you, making openSUSE controls GRUB solved it for me. This page helped a lot: https://en.opensuse.org/SDB:RepairMBRafterWindowsinstall

Madno gravatar imageMadno ( 2017-07-12 04:38:27 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-07-11 08:41:31 -0500

Seen: 385 times

Last updated: Jul 11 '17